Setting up node on RPi 5

Hello everyone.
I am trying to setup new Storj node on Raspberry Pi 5 with ubuntu OS.
I have internet access thru CG-NAT but i have worked around it with portmap before.
So, i have set up port forwarding as before on portmap:

Opened SSH tunel with comand showed above, everything seems right. Portcheck shows port as open:

Screenshot from 2024-06-03 22-03-57

Started my node with theese parameters:

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967/tcp
-p 28967:28967/udp
-p 127.0.0.1:14002:14002
-e WALLET=“0xB5898740d6dfb8D1447eAF2C909ACAe43629B7eB”
-e EMAIL="stoliknakawe@gmail.com"
-e ADDRESS=“StolikNakawe-47776.portmap.io:47776
-e STORAGE=“10TB”
–user $(id -u):$(id -g)
–mount type=bind,source=“/mnt/storj1/Identity”,destination=/app/identity
–mount type=bind,source=“/mnt/storj1/storage”,destination=/app/config
–name storagenode1 storjlabs/storagenode:latest

Node is running but offline:


/

and logs show that it cannot connect to satelites etc.

/

I have set up few nodes already and have no idea what’s wrong. Turned off whole firewall just in case with no effect. Any ideas? It has to be something stupid that i cant notice

Seems to me like something on Portmap’s side. Your docker command seems to check out.

Does public port 47776 definitely map to port 28967 on your CGNATted IP address?

The other thing you could try (and I know I’m clutching at straws here) is to remove the quotation marks on the ADDRESS field. I have absolutely no idea why but I’ve had similar spurious problems and sometimes removing them seems to solve it.

Do you have internet on your node?
What does curl ifconfig.me/ip show you?

You need to use straight quotes, not curly ones, allover you use them. When edit commands, use Notepad++, not the standard Notepad. The last one changes the quotes to unusable ones.
The only place you used the correct ones is the email. And you should mask your personal info. No need to post it.

2 Likes

The portmap does not forward all traffic, so the external IP of the ISP here wouldn’t help.
This type of VPN forwards only one port and one protocol at a time (unless you have a paid subscription).

@Mewosh What confuses me, that

but it’s actually closed, if you would try to open it in the browser. So either right now the tunnel is not running (and it’s closed now for me), or you run it in the other place or the node is stopped.

yea, im writing this from RPi, command gives me my IP adress

I have tried thing with quotes and i think it’s just forum changing those quotes to “smart” ones. I’m using plain ubuntu text editor and even changed all quotes directly in terminal window with no effect.

1 Like

Yes Alexy, i turned it off but i will left it powered if you would like to check it once more

You may check it yourself - open the external address with the port on your phone in the browser using the mobile internet and not WiFi.
It should return a json response.

Nah, i cannot connect to external address. Does it mean it’s something wrong with portmap?

Likely yes, or the port forwarding command/config is wrong.
You may try to recreate the rule. You may also try to change the local port to another one (and update it in your docker run command too).
It’s also possible that you need to enable this port in the firewall (if you use it on your Raspberry) and you may try to use a localhost binding in the port mapping, i.e. -p 127.0.0.1:28967:28967, because your port-forwarding command bind to the localhost (perhaps you need to replace localhost to 127.0.0.1 in your ssh command).