Starting over from scratch


I run my node on Ubuntu 18.04 LTS through Docker.

A few months back, I swapped out my firewall box, and then upgraded to fiber to the home internet. When I swapped the firewall, I forgot to add the port forwarding for the Storj Node. My node was suspended. I finally realized what was happening and opened the ports, only to have my node disqualified.

Before doing enough research, I went in an deleted everything and tried to reinstall it and start over. I have gotten as far as confirming the identity, but when I start the node, the dashboard is unreachable.

What all do I need to delete, so I can actually start over from scratch?


Hi Redlance, welcome.

Did you try to use your old identity, or did you create a new one? I new identity will need to be created. You can use the same email address if you wish.

Are you unable to reach both the CLI and web dashboards? You should check the storagenode logs to see what the error messages say.

I am assumning this is another Ubuntu / docker node.

Recently a setup step has also been added. You can’t just run your node with the docker run command the first time anymore. Refer to for full details.

1 Like

I did use a new identity with the same email address.

I didn’t try the CLI dashboard, I did run the docker command that show what is running, and it said it was restarting.

I’ll update this thread after I get home and can see what all is really happening…

Thanks for the help so far.

I did run the setup command and I it said there was an existing config. do I need to go in and delete that old config and run setup again?


Yes, if you’re starting over you need to start clean with everything.

So delete the old config file and run setup again? Or do I have to delete the old config file, and the identity I just confirmed, and then restart with a new identity again?

If it was never online with that identity you can use it. But delete everything that remains in the data folder before running the setup command.


Thanks everyone, it looks like I am back up and running!