Storage node dashboard shows offline

Hello all,

I am running a storage node for 4 months now and suddenly my dashboard is showing that I am offline. I have a software that shows incoming and out coming data and I can see that my HDD is being actively used. Storage node and storage node updater services are running. Any one experiencing this issue?

do you have windows GUI or some docker version?
What your logs show?

Welcome to the forum @ziebra!

Which browser are you using to see your dashboard ?

Im using windows gui (http://localhost:14002)

In the log file (5gigs of size) I see dowloaded and uploaded pieces. Sometimes error I/o not ready. Do you want a more detailed log?

Im using opera to view the gui

Try using Chrome/Firefox/Edge instead.

Edge shows offline aswell

Can you show this error ?

Also try to see your dashboard. Please try Chrome as well

2020-08-17T17:21:16.433+0300 ERROR piecestore failed to add order {“error”: “ordersdb error: disk I/O erro
r: The device is not ready.”, “errorVerbose”: "ordersdb error: disk I/O error: The device is not ready.\n\

Sorry no chrome installed showing offline

How is your HDD connected ?

10tb hdd connected via usb

It might not be connected properly. Try to use another USB port. Shutdown your node properly. Don’t abruptly remove your HDD.

I took your advice and shut down my laptop and booted it back up. After the reboot I tried to start the service and got a FATAL error:

I cannot paste it fully but it says : {“error”: "Error starting master database on storagenode: storage node database error: file is not a database

Please, check your databases (this guide doesn’t help to fix the “file is not a database”, but can help to find which one is corrupted):

Followed the guide. orders.db has this error. The 13step on the guide (.read notrans file) I get an error:
Error: near line 1: near “?PRAGMA”: syntax error

  1. Exit the session (.exit)
  2. delete the orders.db
  3. execute with sqlite3 (use actual path)
sqlite3 /path/to/orders.db

When you see a sqlite> prompt execute the script:

CREATE TABLE unsent_order (
                                                satellite_id  BLOB NOT NULL,
                                                serial_number BLOB NOT NULL,
                                                order_limit_serialized BLOB      NOT NULL, -- serialized pb.OrderLimit
                                                order_serialized       BLOB      NOT NULL, -- serialized pb.Order
                                                order_limit_expiration TIMESTAMP NOT NULL, -- when is the deadline for sending it
                                                uplink_cert_id INTEGER NOT NULL,
                                                FOREIGN KEY(uplink_cert_id) REFERENCES certificate(cert_id)
CREATE TABLE order_archive_ (
                                                satellite_id  BLOB NOT NULL,
                                                serial_number BLOB NOT NULL,
                                                order_limit_serialized BLOB NOT NULL,
                                                order_serialized       BLOB NOT NULL,
                                                uplink_cert_id INTEGER NOT NULL,
                                                status      INTEGER   NOT NULL,
                                                archived_at TIMESTAMP NOT NULL,
                                                FOREIGN KEY(uplink_cert_id) REFERENCES certificate(cert_id)
CREATE UNIQUE INDEX idx_orders ON unsent_order(satellite_id, serial_number);
CREATE TABLE versions (version int, commited_at text);
  1. Start the storagenode
  2. Check your logs

I reached my new user message limit: This message is concerning:

Log showing downloading and uploading data pieces. Node is working. My original issue of gui showing offline is also solved. Thank you

1 Like