Storage Node Offline and Port Not Open?


This is what I added to my router for the port forwarding. That IP address is the IP address that I get when I type what is my IP into chrome. That is the external address I am assuming. Therefore the port should be open correct or does there have to be something on it? All I know if I put that in place on the router configurations and when I go to the website Open Port Check Tool I test the port and it says it is closed? What could it be?

The external address is in “Public IP Address” column, not the address what you typed in your browser to access the router’s console. The address you typed is a local IP address of your router inside the local network, it’s not accessible from outside.

The port will be opened if:

  • you have a public IP, i.e. your WAN IP on the status page of your router is match the IP on yougetsignal;
  • you made a port forwarding rule to the device with storagenode for port 28967 (or any other, which you assigned to your node in its configuration or docker run command);
  • you added exception rule to your firewall to allow any incoming connections to port 28967 (or any other, which you assigned to your node in its configuration or docker run command);
  • the destination service is running (i.e. your storagenode is up and running and not restarting).

I have done all these things the only thing that is current is that I have taken down the node. How do I go about testing the port when the node is not running?
The WAN IP matches the IP on yougetsignal. I made a port forwarding rule. I also have a rule on my windows 2012 to enable the inbound port from to come in coming.

It’s not possible to test, except run some other service with the same port instead of storagenode.