Storage node preflight database error: storage_usage: expected schema does not match actual

Same thing happened to me, the dash works for a few moments but shows status as offline and then shuts down. Looking in Docker the container was getting some errors. I stupidly tried to re-create it and still have the same issue but now all my stats are gone so I guess I lost the months earnings.

I was using docker and uninstalled it to use the Windows GUI a few weeks ago. I like it a lot more, much easier to manage. My issue was with the Dashboard in the browser and when I used the 127.0.0.1:14002 instead of the default LocalHost it worked again. At first it looked like all my data was cleared but it was still there.

Welcome to the forum @bhj35!

Can you show your dashboard and last 20 lines of log ?

If you are referring to stats that are derived from the logs (such as via the successrate.sh script), the reason these are reset is because when you removed the container you removed the logs. Your earnings are not lost in this case, since the satellite has all the information required to pay you. So long as your node is still working, you will not have lost anything.

1 Like

The dashboard won’t load up and I’ve noticed for the past couple days the docker container running on Ubuntu 18.04 keeps restarting so I assume it hasn’t been running. It seems this is the error causing it:

https://pastebin.com/jwtra5dR

Hello @bhj35,
Welcome to the forum!

Your database is failed to pass preflight checks.

  1. Stop the storagenode
  2. Execute either with a local installed sqlite3 or with a docker container (for ref: https://support.storj.io/hc/en-us/articles/360029309111-How-to-fix-a-database-disk-image-is-malformed-):
sqlite3 storage_usage.db
drop table test_table;
.exit
  1. Start the storagenode and check 20 lines of your logs again.

Huge Thanks! It’s back up and running now. Now my only question is since it’s been offline for 2 full days and I just setup storj about 2 weeks ago, am I better off just leaving it as is, or clearing everything and starting over? I’m assuming my reputation would be quite poor even though it still shows 98% in the uptime checks.

The disqualification for downtime is currently disabled:


So, it should recover the lost reputation during uptime.

Great, thank you. I’ll experiment with it and add a second hard drive if all is good.