Storagenode doesn`t work

What does your log show ?

i know this is kinda stupid, but did either of you check that you are on the global ip you think your are on?

else there seems to be some minor issues with the current release which maybe could affect the start up of new nodes…

@Darthsaiber if your dashboard say online, then it should be fine… new nodes are kinda slow to get started and there are issues right now… so

I know, you are sure that you checked everything and absolutely sure that you should have a static public IP, however, please, go to the main router page (or Stats page) and write down the WAN IP.
Then go to the and compare those IPs. If they do not match - the port forwarding will not work.

You didn’t say that you have a DDNS address, so I can assume that your contact.external-address: option in the "C:\Program Files\Storj\Storage Node\config.yaml" contains a previous public IP with port. If your public IP has changed - you do not have a static IP and need to have a DDNS to avoid changing it every time in the config when the public IP has changed.

I have reviewed my public IP and the port, both the public IP that shows various pages when querying the IP and the public IP that the router shows, are the same. I have tried the port several times and I have changed to another ISP that I have as a backup and it does not generate traffic in the same way.
Check the configuration file “C: \ Program Files \ Storj \ Storage Node \ config.yaml” and it contains the assigned and working DDNS.

The node ID is:

DON’T use “exposed host” for this PC, especially if it’s a Windows PC and you don’t know what you’re doing. It might not solve your problem, but it is generally a bad idea to enable it.

Please, try the Ctrl-F5 on the dashboard. If you have an Online status on the dashboard - then it working.

1 Like