Storagenode doesn't started after update by watchtower

Same here. After auto-update of node via watchtower on Linux, it did not start automatically. When I tried to restart dashboard, docked said that there is no such node. Had to create node once again manually and now it works fine (version do shows 1.4.2 now).

So it’s known now that if we’re relying on and using watchtower to auto-update docker node, that the node is not going to auto-restart after the update? If this is the case, then it kind of makes me want to disable watchtower so that it doesn’t auto-update when I’m not around causing node to stay offline for potentially hours…

This post is about the windows storagenode-updater service.

@Krimarai If there are issues with watchtower as well, it might be best to start a new topic and provide a little more detail.

2 Likes

I moved the issue to the separate thread now. This topic will be about the docker and watchtower

@dragonhogan there is no known issue with the latest watchtower

@Krimarai Is your node online?
If not, please, provide the last 20 lines from the logs

docker logs --tail 20 storagenode  

I would recommend to stop and remove all instances of watchtower and run it again with a new version:

2 Likes

No, it’s not. Worked here for 5 nodes without problems as usual.

2 Likes

@Alexey yeah, after I re-created node, it stayed online so far without issues.
Now that I think about it, the reason for that problem, maybe, was due to the fact that I’ve migrated storj data on a new HDD, so in process of doing so I had to rm my node and then create it again. While doing that I did not stop nor did I restart watchtower. After successful migration of data I just made sure that watchtower is running by trying to start it with console and receiving reply that it already is running.
Also, I had minor internet issues on the day when update was installed and node running container just disappeared - connection dropped several times for a small period - like 30 seconds or couple of minutes, if that may have something to do with problem.
Anyway, I will see what happens on next update and if there is anything wrong I will try to provide log.

No problem with first docker node to update and restart. So must have been a one off issue.

You should stop and remove them all:

docker rm --force $(docker ps -qf ancestor=storjlabs/watchtower)

Then run it again: https://documentation.storj.io/setup/cli/software-updates#automatic-updates

2 Likes

It seems I have found what is wrong in my case. For some reason, a very first instance of watchtower still persisted, while new one worked as well.
изображение
this is a screenshot of “docker ps -a” command, the last watchtower in a list was active for 8 months, so I just removed it.