Storagenode-updater Invalid Host Name -> Can't Update Past v1.49.5

I have had my node operating for 1+ years, but for months I have been unable to update past storjlabs/storagenode:6e7a89161-v1.49.5-go1.17.5-amd64. Everytime I do, the container wont start and the logs show:

--2022-08-18 22:13:28--  https://version.storj.io/processes/storagenode-updater/minimum/url?os=linux&arch=14004
Resolving version.storj.io (version.storj.io)... 35.232.172.28
Connecting to version.storj.io (version.storj.io)|35.232.172.28|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-08-18 22:13:29 ERROR 404: Not Found.

http://: Invalid host name.
downloading storagenode-updater

I am using Unraid 6.10.3 (has libseccomp=2.5.1) and in the container I’ve tried to set the dns to 8.8.8.8 and use --restart unless-stopped. I’ve tried pretty much every suggestion on the forums I can find about the storagenode-updater or anything that has to do with unraid.

Hello @neelybd ,
Welcome to the forum!

Please update the storagenode image:

docker pull storjlabs/storagenode:latest

then try to run it back, but use the :latest tag, not the specific one.
To automatically update the base image we recommend to run watchtower: Software Updates | Storj Docs

Please also make sure that your ADDRESS option in the docker run command doesn’t contain http:// or https://, it should be a plain hostname, not a site, i.e. -e ADDRESS=my.ddns.org:28967

This is a very weird arch, unlikely this arch is exist and it is not supported for obvious reason.

Please try to add a GOARCH variable to your docker run command: -e GOARCH=amd64

I have a feeling, that your docker run command is misconfigured. Please post it here (you may mask the private information) between two new lines with three backticks, like this:

```
docker run -d --restart unless-stopped --stop-timeout 300 \
    -p 28967:28967/tcp \
    -p 28967:28967/udp \
    -p 127.0.0.1:14002:14002 \
    -e WALLET="0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" \
    -e EMAIL="user@example.com" \
    -e ADDRESS="domain.ddns.net:28967" \
    -e STORAGE="2TB" \
    --user $(id -u):$(id -g) \
    --mount type=bind,source=/mnt/storj/storagenode/identity,destination=/app/identity \
    --mount type=bind,source=/mnt/storj/storagenode,destination=/app/config \
    --name storagenode storjlabs/storagenode:latest
```

Well, just adding the -e GOARCH=amd64 worked perfectly. Thank you.

Just for anybody else that runs into this problem, for Unraid, under the advanced view, add
Extra Parameters: -e GOARCH=amd64 --restart unless-stopped

Now as for the reason for why this occured, I’m at a loss. I am using the docker gui (I loosely call it a gui, more of a guided docker create statement, but it helps keeps all of my dockers organized) Just for reference.

here is your problem. You used the GUI and specified GOARCH as 14003 for unknown reason. I would recommend to remove this variable, if this is impossible, you need to specify amd64 instead.
Most of the problems are coming from usage of a generic GUI for containers, they usually misleading and in the past may lead to disqualification. Please use CLI to avoid confusion.