Storj custom domain not working

As you said i setup it like that but still not working my subdomain doesn’t work. Error | Storj DCS (

1 Like

Hello @shajal,
Welcome to the forum!

Your registration information on the domain is missing.
it should have:

$TTL    3600
server 	 	IN	CNAME
txt-server 	IN	TXT  	storj-root:<bucket>/<prefix>
txt-server 	IN	TXT  	storj-access:<access key>

what is
and i setup in cloudflare

What Is $ORIGIN i don’t use my main domain

This is a “subfolder” inside the bucket. Object storages supports only buckets and objects, the prefix is a part of the object name, but can be visualized as a subfolder.
If you do not use prefixes, then you do not need to specify it in the TXT record.

It’s your main domain. This is a usual declarative description for your domain. You can register CNAME only for subdomains, in this case

Your screenshot with DNS records looks almost correct, but you need to remove a trailing slash from the bucket, if you do not provide a prefix after. Please note, SSL is available only for paid accounts, if your account is not paid, it will not work.
On CloudFlare you need to switch to a Flexible mode for encryption, unless you have a paid Storj DCS account, then you can use SSL option and enable Full (strict) mode: Setting Up Custom Domains - Storj Docs

Right now your TXT record for storj-access: in your DNS is incorrect, you need to specify there not your access grant, but access key from S3 credentials, created for this bucket when you used a command

uplink share --dns sj://pixahunt

It prints needed records at the end.
You need to use the access key jv26qxslzuip7t2wuk7bd4ik4baq: IN      TXT    storj-access:jv26qxslzuip7t2wuk7bd4ik4baq
1 Like

i complete everything but not working

Now it works, but needs correct permissions:

Did you remove the root access grant from the account? If so, all derived accesses are revoked.
You may check:

uplink ls sj://pixahunt

If it’s still working, then you need to generate a valid access (valid for 2 hours):

uplink share --dns --not-after=+2h sj://pixahunt

or valid indefinitely:

uplink share --dns --not-after=none sj://pixahunt

and update your storj-access: record in DNS.

1 Like

it’s work. will my link ever change?

1 Like

What do you mean?
It may change, if you update registration or configuration of your DNS, you may also move objects to a different bucket or use prefix(es) inside the bucket.

sir i want to off Switch passphrase

What do you mean? If you are talking about access your buckets and objects via Storj Console (the Satellite web UI), then it cannot be disabled - we doesn’t store your encryption phrase, it may be temporary stored in your local browser session, but as soon as you refresh the page - it will be lost and you will need to provide it again.
Please use the same encryption phrase used during upload to get an access to these objects.