StorJ Docker constantly rebooting

Hello, I tried to make a test node to see if I get storj up and running before investing, and I have some problem with the docker instance rebooting over and over. I am rolling on a pi 4 4gb. and these are the steps I tried.

So first init

docker run --rm -e SETUP=“true” --mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode/",destination=/app/identity --mount type=bind,source="/home/pi/disk1/storjTestNode",destination=/app/config --name storagenode storjlabs/storagenode:latest

Actually running the node

docker run -d --restart unless-stopped --stop-timeout 300 -p 28967:28967 -p 127.0.0.1:14002:14002 -e WALLET=“xxx” -e EMAIL="email@email.com" -e ADDRESS=“1.2.3.4:28967” -e STORAGE=“0.25TB” --mount type=bind,source="/home/pi/.local/share/storj/identity/storagenode/",destination=/app/identity --mount type=bind,source="/home/pi/disk1/testNode",destination=/app/config --name storagenode storjlabs/storagenode:latest`

I tried a new folder as well here because I read on the pages that having a config.yaml in the folder could be a problem. The weird part is, that config.yaml that the first command creates has everything commented out, and the things that are not commented out, are empty strings.

This is the docker log(removed the 1000 million same lines):

2021-03-20T17:22:17.480Z INFO Operator email {“Address”: “email@email.com”}
2021-03-20T17:22:17.480Z INFO Operator wallet {“Address”: “xxx”}
Error: Error starting master database on storagenode: group:
— stat config/storage/blobs: no such file or directory
— stat config/storage/temp: no such file or directory
— stat config/storage/garbage: no such file or directory
— stat config/storage/trash: no such file or directory

What is my next step?

In setup you set this as storagefolder
type=bind,source="/home/pi/disk1/storjTestNode",destination=/app/config

But in running command you set this as storagefolder

type=bind,source="/home/pi/disk1/testNode",destination=/app/config

Its not same

Welcome to the forum @BigShotPunchAndJudy !

Minimum storage needed is 500GB + 50GB for overhead

2 Likes

Which means the minimum storage that can be configured for the node is 500GB, but it should run on a disk that has at least 550GB of available space for STORJ. If I may :slight_smile:

2 Likes

You missed the setup step: Storage Node - Storj with the same folders as in regular docker run command

You run setup for the /home/pi/disk1/storjTestNode but trying to run for /home/pi/disk1/testNode

1 Like

I tried it in the same folder as the setup, but that gave the same error, so I tried it in another folder.

But it seems the minimum size is 550 GB (I do not remember this from years ago when I set up a node with just 32 GB lol). I will try a bigger disk and report back.

It must be a different error, if you setup it with the right folder.
The error when you have less space than a minimum will be “Total disk space less than required minimum”

The thing is that unless you fiddle with advanced options, the node will refuse to start with less than 500GB of storage space configured, with a clear message in the logs about that.
On the other hand, the 550GB (more precisely the 10% of extra space) is just a recommandation to be safe; but the node won’t refuse to start if you do not leave 10% percent of extra space available on your disk.

1 Like

I see I am missing some folders according to the error, I will manually create them to see what happens.

edit: Bigger disk same commands(folder locations the same) the thing now works. Only strange thing is that I can’t access the web gui thingy to say status. This is my cli status:

Storage Node Dashboard ( Node Version: v1.24.4 )

======================

ID someNumber
Status ONLINE
Uptime 2m36s

               Available     Used     Egress     Ingress
 Bandwidth           N/A      0 B        0 B         0 B (since Mar 1)
      Disk       0.70 TB      0 B

Internal 127.0.0.1:7778
External :28967

I am not sure why the internal port is 7778, but navigating to that doesn’t work either.

To access your web dashboard you can use a remote access: How to remote access the web dashboard - Storj
If you want access it only inside your network, then you can remove 127.0.0.1 from the port mapping -p 127.0.0.1:14002:14002 in your docker run command to make it -p 14002:14002. To update any parameter, you should stop and remove the container

docker stop -t 300 storagenode
docker rm storagenode

and run it back with all your parameters include changed ones.

1 Like

Ahhh thanks. That also seemed to be the way to increase the storage parameter. And with the identity and storage locations unharmed, it all works out. Thanks, the dashboard works now.

1 Like