Storj installation on Freenas

Hi,

I am running storj on Freenas. It is currently running in a Ubuntu VM with docker.

Today I created a new node, let it run for a few hours to receive some data, then tried to move it into a Jail using the native FreeBSD binary I found here:
https://forum.storj.io/t/will-freebsd-freenas-support-be-added/2851/9?u=rmon

I edited config.yaml to point the node to the existing identity and data files.
When I started storagenode, the system tried to migrate the db, then died with the error below:

root@storj1:~ # ./storagenode run
2020-07-22T16:10:31.883+0200 INFO Configuration loaded {“Location”: “/root/.local/share/storj/storagenode/config.yaml”}
2020-07-22T16:10:31.890+0200 INFO Operator email {“Address”: “"}
2020-07-22T16:10:31.890+0200 INFO Operator wallet {“Address”: "
”}
2020-07-22T16:10:37.338+0200 INFO Telemetry enabled
2020-07-22T16:10:37.342+0200 INFO db.migration.40 Add unknown_audit_reputation_score field to satellites db
2020-07-22T16:10:37.442+0200 INFO db.migration.41 Make satellite_id foreign key in satellite_exit_progress table
2020-07-22T16:10:37.500+0200 INFO db.migration.42 Drop used serials table
2020-07-22T16:10:37.565+0200 INFO db.migration Database Version {“version”: 42}
2020-07-22T16:10:38.167+0200 ERROR trust Failed to fetch URLs from sourc{“source”: “https://tardigrade.io/trusted-satellites”, “error”: “HTTP source: Get https://tardigrade.io/trusted-satellites: x509: certificate signed by unknown authority”, “errorVerbose”: “HTTP source: Get https://tardigrade.io/trusted-satellites: x509: certificate signed by unknown authority\n\tstorj.io/storj/storagenode/trust.(*HTTPSource).FetchEntries:63\n\tstorj.io/storj/storagenode/trust.(*List).fetchEntries:90\n\tstorj.io/storj/storagenode/trust.(*List).FetchURLs:49\n\tstorj.io/storj/storagenode/trust.(*Pool).fetchURLs:240\n\tstorj.io/storj/storagenode/trust.(*Pool).Refresh:177\n\tstorj.io/storj/storagenode.(*Peer).Run:688\n\tmain.cmdRun:200\n\tstorj.io/private/process.cleanup.func1.4:359\n\tstorj.io/private/process.cleanup.func1:377\n\tgithub.com/spf13/cobra.(*Command).execute:840\n\tgithub.com/spf13/cobra.(*Command).ExecuteC:945\n\tgithub.com/spf13/cobra.(*Command).Execute:885\n\tstorj.io/private/process.ExecWithCustomConfig:88\n\tstorj.io/private/process.ExecCustomDebug:70\n\tmain.main:320\n\truntime.main:203”}
Error: trust: failed to fetch from source “https://tardigrade.io/trusted-satellites”: HTTP source: Get https://tardigrade.io/trusted-satellites: X509: certificate signed by unknown authority.

When I tried to restart the node on docker, the node could not restart any more (the log was showing some database issues).
I tried to repair the DB, but accidentally deleted one table in the process (!), so now the node is unusable.

I’ll just drop this node and restart from a clean installation.

Questions:

  • is anybody successfully using storj on a Freenas node with the native binary?
  • any suggestion on how to migrate an existing linux node without breaking it?

Thanks!

You can see people running the storagenode on freeBSD: https://forum.storj.io/tag/freebsd
Regarding migration: https://documentation.storj.io/resources/faq/migrate-my-node

Regarding migration: https://documentation.storj.io/resources/faq/migrate-my-node

That’s the guide I followed. And I did this a couple of times already to migrate a node between different disks in my docker server.

Problem is that when I tried to launch the node in Freenas, it broke my DB files.

The log in the OP was also showing a X509 certificate error.
I solved it this way:

pkg install ca_root_nss

Roberto

Then my guess would be that you didn’t run step 8 as instructed. Running that step without the --delete option would lead to database corruption.

Running that step without the --delete option would lead to database corruption.

I did use the --delete option.
Anyway, no need to troubleshoot further. I’ll start again from scratch and see what happens.