STORJ node on Pi4 self DDOSing?

I seem to run into this issue several times a year where all ethernet devices stop communicating on the router (though WiFi connected devices work fine) and only after physically disconnecting the Pi4 that runs my storagenode does it restore communication (replugging it will kill ethernet again within a few minutes).

I swapped out my router a couple of months back but it doesn’t seem to have helped. Normal operation only resumes after a hard reset of the Pi4 (which I always feel super sketchy having to do). I run inside a docker container on a Pi4 and first started having this issue about 2 years back (been online since 2019).

It really does feel like a self DDOS. Anyone else experience this or know what the issue might be?

Cant say ive have any issues like this and Im running 2 RPI4s maybe your router cant handle the amount of connections.

1 Like

Did you change the cable? Sometimes there are oxydated pins in the cable or ports.
If the contacts become dark brown like old copper coins its over and goes away after replugging. They have to be like new golden coins.

maybe post pics. top view and front view of the cable and inside of the conector slot.

Might be that the NAT table on the router is not enough to handle as many concurrent connections as a storage node might receive.


wich one do you have? same type as old one or other?


TP-Link AX6600 now. Was previously an ASUS AC2400. Both were pretty expensive when new, however, I do have issues sometimes with WiFi devices just not being able to connect (home IoT - lots of small devices that connect) so its possible that both routers are just choking.

Ethernet wires themselves look okay, one thing I will note though is that they’re connected through an ethernet hub.

I’m not above trying another router swap, if you have a good suggestion. Something with OpenWRT perhaps. Switching ISPs soon though so I’ll be getting one of their stock routers I’d imagine

Wich one? Its maybe the igmp v3 problem.
If the router wants to do igmp v3 and other devices like hubs don’t support it or only v2 they downgrade the router to their level and v3 streams act as ddos “attack”. Look deep into the technical spec of the hub. (It should be a switch. Not a hub. They are outdated long ago.)

From where to what provider.

Ah sorry, wrong terminology, it is a switch not a hub. Just a cheapo 5 port TP link gigabit switch (TL-SG105)

as i read in the manual, its impossible to know wich igmp version it has.
regardles the hardware version.

Maybe try something else besides TP-Link. They are a cheap option and of course low performance.
As switches with no choke problems I have Dlink Gbit switches, the all metal models 8/16 ports with PoE. As routers I used TP-link, but they don’t have autoupdate and fewer VPN options. I preffer Asus AX models that support Wireguard. You can search the Asus website for “Asus Wireguard”; you will find a guide that points to a page with models that support it, like RT-AX58U, 68U, 86U etc. You can compare the CPU and RAM between models. You will find 2/3/4 cores and 512MB/1GB models.

Both of there routers seem powerful enough to handle lots of connections. Does your current router provide any access to internal logs?

The logs on it are abysmal, I’ve exported all of the logs going back to 6th Sept but it only seems to log starting up. There are logs from 29th October too but this was me rebooting it again. There’s nothing between 06.09 and 29.10. According to another deice on the network, I reckon it went down at about 17:50 on 28th.

As for connections, yeah, I have tried to pick routers that could handle 80+ devices (I have 60 ish on my network)

1 Like

I don’t really have any good advise then. I would really try to figure out what is the root cause before I would go for yet another device. Though, if you choose to, at your scale with 60 devices you might want to try SOHO solutions, as opposed to even high-end consumer devices.

I’m using ZyXel routers, because TP-Link, D-Link and other similar crap, include ASUS, cannot handle a lot of connections, because they uses weak processors and small memory, uses bloat firmware (ASUS), they also is very sensitive to the power quality (beside the fact they are deliver them with a crap AC adapters - TP-Link and D-Link), I will not trust them anymore (around dozens devices from these manufactures from consumer/SOHO lines for several painful years).
Perhaps this firmware

could fix some childhood diseases of the original firmware, but cannot fix the hardware. However, I read on their forums, that sometimes it can fix almost all issues (except power quality sensitivity).

1 Like

the maximum on wlan devices is 64 per frequency 2.4 / 5 ghz

so both bands should be active.

get rid of the cheap ass switch and get one where igmp v3 is stated in the specs.
switch the patchcords for the pi. cat5e minimum.

1 Like

If not aready noticed take care of this.

@JackReevies, were you able to resolve this issue? ive been experiencing the same since late last year or early this year. i also use rpi4. whenever the issue occurs, i disconnect and reconnect the network cable, and ive observed that the problem stops when my node is suspended. however, once the status returns to 100%, the issue resurfaces. im curious to know if you managed to find a solution and how you approached it.

This is likely the consequence of

However, it should rule itself: