Storj node service not starting after power off (win gui)

After power off storj node service fails to start with error 1067. Log file is not being written when trying to run service . Seems to me that the storage node service is not trying to read any data from the database or storage folder. Is there any way to get information about the causes of the error?

I don’t use Windows, so I can’t help you directly, sorry. But have you tried searching the forum for this error? I see a lot of people experienced it already: Search results for 'error 1067' - Storj Community Forum (official)

1 Like

I checked *.db files with sqlite(all ok). The disk check found no problems. I have not found information anywhere why the log is not being written. I don’t know what is wrong. Perhaps it is worth reinstalling the storj node application for windows?

I would be very surprised if the log file isn’t being written to. If that is the case then it points to a possible permissions error as the user being used to run the node doesn’t have rights to the log file (or containing folder).

1)is disk free space more then 500 gb?
2) stop storj service, delete current log file, run service again
3) try manually update your version to most recent
4)check acl (access rights for this directory)
5) check this thread also Windows node cannot start, stop, restart or reinstall. I will be disqualified :frowning: - Node Operators / troubleshooting - Storj Community Forum (official)

I have seen something like this, after windows made some update, in C disk appeared folder Prorgam with some old staff, and windows tried to find node files there.

Only a complete reinstallation of the storj program helped. I saved orders, database and identity and the service started. Now I have another problem: QUIC Misconfigured and many errors

2023-02-11T18:11:33.835+0200 ERROR contact:service ping satellite failed {“Satellite ID”: “12tRQrMTWUWwzwGh18i7Fqs67kmdhH9t6aToeiwbo5mfS2rUmo”, “attempts”: 10, “error”: “ping satellite: failed to ping storage node, your node indicated error code: 0, rpc: tcp connector failed: rpc: tls peer certificate verification: not signed by any CA in the whitelist: CA cert”, “errorVerbose”: “ping satellite: failed to ping storage node, your node indicated error code: 0, rpc: tcp connector failed: rpc: tls peer certificate verification: not signed by any CA in the whitelist: CA cert\n\*Service).pingSatelliteOnce:147\n\*Service).pingSatellite:101\n\*Chore).updateCycles.func1:87\n\*Cycle).Run:99\n\*Cycle).Start.func1:77\n\*Group).Go.func1:75”}


2023-02-11T18:18:20.813+0200 ERROR piecestore download failed {“Piece ID”: “7HAYQSHMVYMSQWXPH3DW4S4R7DZUN65HFYQHBI3UJWGMDV3PLEEQ”, “Satellite ID”: “12EayRS2V1kEsWESU9QMRseFhdxYxKicsiFmxrsLZHeLUtdps3S”, “Action”: “GET”, “Offset”: 0, “Size”: 0, “Remote Address”: “”, “error”: “file does not exist”, “errorVerbose”: “file does not exist\n\\n\*Endpoint).Download:640\n\\n\*Mux).HandleRPC:33\n\*Handler).HandleRPC:61\n\*Handler).HandleRPC:42\n\*Server).handleRPC:122\n\*Server).ServeOne:66\n\*Server).Serve.func2:112\n\*Tracker).track:52”}

:arrow_up:This error was before, but not 20% of all rows.

did u saved yaml configuration file?

Yes. Node started on the old config.

no egress in 30 minutes

did u made any changes in IP for host?
try to disable firewall and restart your node

1)what port is used in yaml config file?
2)restart your router before restarting your node
3) check if your udp port is opened (the one that is used in 1)

Open Port Check Tool - Test Port Forwarding on Your Router ( try this tool to check your udp port

port 28967
I don’t have a router, I use an unmanaged switch.
Online check says the port is open

do u have only 1 node in this location?

i have 4 nodes on VMs

are they all on the same pc?

change port in yaml configuration file to the other (28900 for example)
restart your node
check your dashboard
your port is opened but used for another node- u have to change it

in this case, the node is offline.

right now your node is configured with external port that is used for another node
check this string in yaml
u will definitely find it duplicated on another node or configured wrong (not the yyyyy u expected)
u have to forward it correctly and again- check firewall !!!