Storj node up for 1 day now its down?

Hey guys I got my node up and running last night and on the windows gui it said that I was online. Now it is saying that I am offline?? How do I get it back up and running

Do you use DDNS or static IP

I am using DDNS. I think its No-IPS

did you instaled IP update software, please chek it.

Not sure if I did. I followed the installation video. Is it the No-IP? If not what is the software?

it shold be some app, that update NOIP when your external Ip changed.


I have that downloaded already

Then please, install and make sure it’s updated to the same IP which you can see there:

Im looking at the DUC and it has matching remote addresses. When i click on check it says port closed

Any suggestions on how to fix it?

Have you opened the port in your router?

I can suggest you to go through the checklist: Node stopped responding overnight. Still shows OFFLINE after restart

Yes i have opened a port (Dont know if i did it right). It was work for at least 10 hrs, then it stopped.

Please, compare the IP from the and your WAN IP on your router.
Please, check your firewall rules.
Please, check the IP of your PC and make sure that you uses the same IP in your port forwarding rule on your router.
Make sure that your external address in the ADDRESS variable (docker) or contact.external-address: in the config.yaml (Windows GUI) contains your DDNS hostname with an external port, which you have forwarded to your PC with storagenode

my ip address does not match. when i enter the ip# from yougetsignal its says server ip address is not valid range my server ipv4 address (in the command prompt ipconfig matches the port forwarding address in my router. my DUC hostname matches the config.yaml file.

You shouldn’t enter the IP from yougetsignal on your router.
The WAN IP is assigned to your router by your ISP, you should not change it.
You should compare it with a public IP from the yougetsignal. If they are different, then your ISP is placed you behind its NAT.
In such case the port forwarding will not work.
You will have a three options:

  • switch ISP to one with a public IP (WAN IP matches the public IP);
  • ask your current ISP to give you a public IP (it could be dynamic, but must be a public);
  • use VPN with port forwarding option, such as PIA, ngrok, purevpn,, …