Storj with google drive

i have a lots of space on google drive. i want to use google-drive-ocaml-fuse as a drive and use this drive for storj node. i use ubuntu 16.04 on vps.
i did everything but now have problem. the thing is storj dashboard will not shows up. it says “container is restarting wait until container is running”. and it never run.
is it problem to fuse mount or another thing? i used many google drive mount software but this one show google drive as real drive not syncing or something like that.

and before this setup i used windows server 2016 on vps with netdrive , that doesn’t work either because the docker need hyper-v and i have lots of problems with vps . for those who want do that i recommend dedicated server , maybe it work.


Hey node, welcome to the forum!

Using google drive for storj is a really bad idea. This will add a lot of additional latency and will really mess with the workings of your node.
The idea of storj is to store data decentralized. If nodes are going to store it on another cloud somewhere, they would also be reintroducing a single point of failure. In short, you should really not be using google drive at all.

However, the debugging steps are the same no matter what you use. Have a look at your docker logs to see if something relevant is mentioned there. docker logs --tail 100 storagenode


I don’t think that it can work because I doubt that sqlite DB and/or Bolt (i.e. kademlia) would work on such configuration.

However the right answer is what @BrightSilence has written.

I just reconfigure it and it works now . in the dashboard i have a problem that every 8 or so hours take to refresh the status but nevertheless it works for now .

A potential issue that you can run into by using fuse system to mount gdrive, onedrive etc is that there will be cases where the program, google-drive-ocmalfuse, will try to upload the sqlite3 db or any other db while it is in use by the storj software hence causing data corruption. It is very likely that in the future you will run into alot of database disk is malformed.


one thing i should notice that i was doing that with Netdrive on windows server 2016 build 14393 , but as i am using vps (with nested virtualization enable) , the docker on windows doesn’t work with Storj container . Netdrive is best software in this context because other programs use syncing for transfer data but Netdrive use real time transfer , like local drive.
i am thinking to wait for beta release of Stroj for windows as standalone program not related to docker or anything else.

VM in VM in VM?
Not a smart choice either.

The Docker for Windows uses the Linux VM under the hood.
So, you: rented out a VPS (VM), installed the Windows, which is enables Hyper-V inside that VM and installed Docker for Windows which installed VM with Linux to work with Linux containers.
Moreover, you have used the Gdrive FUSE for storage.

I’m sure your node would be disqualified in the next few days/weeks. Surprise me :slight_smile:

It’s much simpler just install Linux directly and use the docker from there. It’s much stable than your current setup. But it will not solve the problem with FUSE, described some posts above.

1 Like

Actually VM in VM , windows was VM that docker uses Linux container in VM . i had a lots of problem with hyper-v in VM (windows machine), i run docker without hyper-v and that didn’t work either . so at the end it didn’t work on windows at all and i am currently on ubuntu with FUSE (google-drive-ocaml-fuse). the problem is refresh rate to see uptime is every 8 hours !!!
if someday in the future the Storj will release on windows as standalone software i will use it with NetDrive software . i think it uses WebDav to show cloud as local drive. i think it will work.


The WebDav will not work too. Too slow. As a gdrive.
Your node will fail almost all uploads and downloads. And I can see, your usage is already zero.
Or do you removed all the previous collected data?
If so, your NodeID is disqualified already.

Please, copy the output of commands:

docker exec -it storagenode grep -c BEGIN /app/identity/ca.cert
docker exec -it storagenode grep -c BEGIN /app/identity/identity.cert

Yeah as i said before i think the problem was the software and i reset it without any data collected. at best it was online for 24 hours. i deleted and make new id again . but i then realized that it update uptime every 8 hours or so. i think now it is 14 hours that the picture shows 9 hours.

Looks like your identity is signed.
I would like to know, how high your failure rate, please, run this script: Script: Calculate Success Rates for Audit, Download, Upload, Repair

1 Like

I think i should close the project due to crashing system and poor stability.
maybe in the future with standalone software , i will do it again.
Thanks to you guys for helping me