Storjnode too old, ran update but wont start

so my node stopped since it was too old, I was running 1.96, and when I run the installer to update it, at the end when it attempts to start the node service, it just fails.

Somehow with all of this, my identity folder got wiped. But I have a backup so I restored. But I still get this and of course it doesnt write to the log since the storjnode server isnt running.

I’ve removed databases incase it was that, but that didnt help. I ran chkdsk on the drive, it comes back clean. If I revert back to 1.96 it at least runs and enters into the log that its too old. But what do I do now for 1.99?

Nevermind, I got it. I guess the original problem was the identity being missing. But I didnt notice that until I kept snooping around for other issues with downgraded versions. So I just ran the following - & “$env:ProgramFiles\Storj\Storage Node\storagenode.exe” run --config-dir=“$env:ProgramFiles\Storj\Storage Node\” --log.output=stderr

and saw that even with version 1.98.2 it still complained that it was too old. So since I got the identity back in there, I just tried 1.99.3 again, and it started.

All is good once again.