Storjs jokes: creating access API key at dashboard requires at least one bucket, but creating bucket requires API key

I want to create an access grant to connect via Rclone. The option “Continue In Browser” is greyed out because I have no buckets.

Well, I think, let’s create a bucket…

There is no “create bucket” option in the browser, so I downloaded the “uplink CLI” to create a bucket. The CLI asks for the API key, but I have no API key because the option “Continue In Browser” is greyed out because I have no buckets…

This is funny. Thanks, Storj.

Creating buckets is carefully hidden under the “Object Browser”. Thanks to my years of experience in programming, I was able to unravel the secret of creating buckets after a few wasted hours.

By the way, buckets creating stuck in the Firefox and Pale Moon browsers (most likely due to my restricted privacy settings). I was able to create a bucket only in the Brave browser.

Hmm - sounds like the real issue here is browser compatibility.

Thanks for flagging @jon.farrel - our team will investigate.

2 Likes

Hello @jon.farrel ,
Welcome to the forum!

I tried to create an access grant in the bucketless project using Firefox, the Continue in the browser and Continue in the CLI buttons are available for me.
Please, let me know, what I need to enable in the Firefox to make them grayed out?

The “Continue in the browser” is greyed out for new accounts which has no buckets yet. It is not a web browser issue.

As I said, the “Continue in the browser” button becomes available (not grey out) after creating a bucket in the the “Object Browser” dashboard section. It was just unclear that buckets creating is hidden under that tab.

Since my main issue was that I was not able to find where to create a bucket to be able to create an access grant, the main question is solved.


As for buckets creating tab, you can ignore my technical issues because I have too aggressively restricted Firefox profile with “about:config” modifications. As for creating buckets at Pale Moon, I see TypeError: self.newPermission is not a function error message showed on the EU1 page. Anyway, I do not need any browser because I have API key and can use the CLI.

I created a new account with Firefox on EU1, and selected Uplink CLI in the onboarding overview page, it navigated me to the “create a new access grant” wizard and after specifying a name I was able to create an access grant without having any bucket (the buttons was active).
I have installed uBlock Origin in the Firefox and it was enabled all the time.

So, seems it’s likely a browser issue, not the issue with the wizard. Could you share - what restrictions you have applied? I want to be able to reproduce an issue and share it with the Team.