Strange UI Behavior

I’m seeing strange behavior on my dashboard.
Screen Shot 2020-01-31 at 12.05.09 AM

Mousing over shows that the graph has wrapped around to January 1st 2020. The dip just before that is today’s date, January 31, 2020. The Jan 1, 2020 isn’t available on the left. It starts at Jan 2.

Anyone else have this UI glitch? Happens on Disk Space Used This Month also.

Mine looks fine.

Have you tried to hard browser refresh (i.e. emptying the cache)?

it is fine here.

i think a refresh might help (ctrl+f5)

Yeah, tried a brand new browser and cleared cache on the others. The chart glitch remains.

I have a similar thing:
Capture123


There were 3 node updates yesterday… There was also a issue reported yesterday. I wonder if everybody did not use much bandwidth that day. I run GUI by the way…

Are you talking about bandwidth usage or just the UI glitch reported by @mi5key?

Can you describe your SN environment (docker, Windows, etc.) and which browser are you using for visualizing the dashboard?

https://status.tardigrade.io/incidents/cw3slf93wxjt
Yesterday’s issue.

Same issue here. My graph mouse over labels start with January 02 and end with January 01 with January 31 between them. Node is raspberry pi 4 browser is Firefox (on windows 10). Looks the same on Chromium.

Docker in unraid, works perfectly. This appears to be mostly a UI glitch. Tried in Firefox/Chrome/Safari. Also tried Firefox in Windows, same result.

With the new month start I have a similar issue

Similar but opposite issue for me. Instead of showing Jan 31 in a Feb calendar, mine shows Feb 01 in a Jan calendar.
cal

Same issue here. Showed data for January 1st at the end of the graph.

This issue is caused by wrong use of timeszones by storagenode software.
Data collection/statistic module use UTC time. And dashboard is using local node time (adjusted to local timezone) without proper time conversion.
This produces some strange glitches as there are 2 different moments for start of each day and each month:

  • one start of day/month by UTC time
  • one start of day/month by local node time

Glitches will differ based if node is ahead of UTC (UTC+xx) or behind (UTC-xx). And only users from GB (local time = UTC/GMT time) will get fully correct graphs.

I noticed the same. So the SNOBoard needs to be fixed to use UTC for everything.

1 Like

Today the problems seems solved

1 Like