Synology DNS docker problem

I’ve been running storj since the beginning and everything has been working fine until now. I’m running storj on a Synology RS3618XS. I had a raid volume failure so I had to do a full reinstall but I can’t get storj running again. I followed the setup guide but in the final step using the long command it fails:

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-e WALLET=“0x65E0ac7bb7018b2114a958Fc40AE92193eD1f036”
-e EMAIL=""
–mount type=bind,source=/volume2/backup/storagenode,destination=/app/identity
–mount type=bind,source=/volume2/storj,destination=/app/config
–name storagenode storjlabs/storagenode:latest

The error I get is:
2021-03-21T18:58:25.314009718Z 2021-03-21T18:58:25.313Z ERROR Invalid configuration. {“error”: “invalid contact.external-address: lookup “” failed: lookup on read udp> i/o timeout”, “errorVerbose”: “invalid contact.external-address: lookup “” failed: lookup on read udp> i/o timeout\n\*Config).Ve rify:156\n\tmain.cmdRun:155\n\\n\\n\*Command).execute:842\n\*Command).ExecuteC:950\n\*C ommand).Execute:887\n\\n\\n\tmain.main:385\n\truntime.main:204”}

Doing a nslookup from the command line works fine for (returns my external ip).

So I tried to enter my external ip directly in the startup command and got a little further but docker can’t lookup

2021-03-21T19:18:47.191546217Z Error: trust: failed to fetch from source “”: HTTP source: Get “”: dial tcp: lookup on read udp> i/o timeout

Something is wrong with name lookup from docker. It’s a plain new install with a untouched docker config. I’m running DSM 6.2.3-25426 Update 3. When I installed this the first time a long time ago there was a good synology specific install guide but it doesn’t seem to be available any longer.

Is there something I need to change in the Synology Docker config to make this work again ?

There is no Synology-specific configuration. The network doesn’t work in your docker installation for some reason.
Maybe you have some kind of firewall somewhere and it’s blocking traffic from your Synology.

We are not using the firewall in the Synology, it’s disabled. We have a lot of other applications running on this server and they are running fine. It’s only docker that has a problem. I got a support ticket with Synology now, we will see what they say.

Hmm, maybe problem just in misprint, you set -e instead of

It was a typo when I removed my real address :slight_smile: Thank you for notice - I’ve edited the original post now :+1:

Problem solved.

This server has multiple gateways and docker don’t like that for some reason … routing sorted out now and everything working.

Any chance to recover from this or is it just to start over again ?

Just keep it online, it should recover in the next 30 days online.