Synology docker gui configuration

I would really appreciate it if someone could provide a step-by-step guide on how to set up the Docker container with the GUI on Synology.

I’ve already followed the official guide and created my identification files, but I’m currently stuck that I don’t know what configurations I need to do in the container.

I have created a shared folder on the nas to be used for this data stored by storj. There are also the identity files.

But I don’t know how to tell the container where the identity files are.

You don’t need to share folders.
Just search for storjlabs/storagenode:beta in the docker station on
You should make a mapping between folders on your NAS and folders inside the container:

  • your folder with an identity to the /app/identity inside the container;
  • yout folder with data to the /app/config inside the container.

You need to specify all values for those environment variables:
After that only run a container.
But for me it’s just more easily to run your command from the shell

thank you for your reply.

I would prefer the configuration with the GUI.

I already added the configurations with and


The identity certificate is at the location, but when I try to start the container, it says it couldn’t find it.

Would really appreciate any help.

Please, remove the “variables” <identity-dir> and <storage-dir>, they are placeholders, which you should replace with real paths. But for GUI you should make the mapping in the different place.
Make mapping in the Volume tab

You should map the port 28967 in the Port tab

Hello, and thanks again.

The port mapping is no problem. Still get the same error that the identity.cert is not found.

You may have any idea where it should be placed?

Thanks a lot.

In the Volume tab, as I said.

The volume tab creates -v mounts, which were removed from the instructions because they can cause problems. I highly advise to use the commands in the instructions instead of trying to replicate them in the GUI.
I don’t think you’ll be able to do it for the watchtower command either.

Just connect over SSH and copy paste the commands, much simpler and the resulting containers will still show up in the GUI. Yet you shouldn’t use the GUI to stop your container either as it will use the default stop timeout which could lead to corruption of the info.db. Don’t make things harder on yourself by deviating from the instructions.


I’m still stuck with the identity file. If I use the following command with SSH:

sudo docker run -d --restart unless-stopped -p 28967:28967 -e WALLET=“XXX” -e EMAIL=“XXX” -e ADDRESS=“” -e BANDWIDTH=“90TB” -e STORAGE=“1TB” --mount type=bind,source="/identity",destination=/app/identity --mount type=bind,source="/storj/data",destination=/app/config --name storagenode storjlabs/storagenode:latest

I get:
docker: Error response from daemon: invalid mount config for type “bind”: bind source path does not exist: /identity.
See ‘docker run --help’.

Could someone tell me where to put the identity.cert on my NAS and what path I should put in the config to reach it?

Thanks a lot again.

The paths you see in the Synology GUI are not full paths. If you have one volume the path starts with /volume1. You can see the full path in folder properties from file station.

Thank you so much for the great help.

I used the absolute paths as mentenion and it worked.

I hope there will soon be a way to use the GUI to set everything up.

Please close.

I don’t think it will be available any time soon.
That is limitation of the Docker implementation on the Synology side (I think) And it is like that for as long as I can remember.
Terminal is your friend :slight_smile:

1 Like

I must correct myself. It is working but my node is offline.

I read in other posts but didn’t came to a solution.

I added port forwarding in my router. And I added a rule in my firewall. I even tried to disable the firewall for a bit.

Says my port is open.

But my node is offline.


As shown above I use the -p 28967:28967 command.

docker exec -it storagenode2 grep -c BEGIN /app/identity/ca.cert
docker exec -it storagenode2 grep -c BEGIN /app/identity/identity.cert

Responds to 2 and 3.

Would appreciate the help as much as always.

Maybe it is because of the warning?

See, this is why I suggested you follow instructions and use CLI. Synology GUI defaults to the :latest tag for the docker image. You should be using the :beta tag. Please stop and remove your container, then follow the instructions starting with docker pull storjlabs/storagenode:beta


Yes of course you are right.

Thank you a lot it is fully up and running.

Now the topic can be closed.

1 Like

It seems working but I got some errors?

You may have an idea what that means?

If you saw it only once - you can ignore it.

@sembeth I am also trying to run a node on my synology but I am no IT guy at all and would like to seek your advise. I got my identity created as well but now the issue is how to pull the right docker (beta version as suggested). Did you use a putty ssh command to pull the docker or did you use the repo browser in the docker window in Synology?

If all goes well I’ll put a tutorial together for others.

Thank you

Welcome to the forum @muten85

I’m on Synology as well.
You’ll need to issue commands over ssh in future steps either way. It’s definitely best to do everything over ssh and stick to the documentation to the letter!

Let me know if you need any assistance.

Thank you @BrightSilence. I am using putty to ssh into my synology from Windows 7 Home but the issue I have is a docker daemon error when I try to pull the container (after navigating to the folder where I want Storj to be installed).
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock.

Thank you!