[Tech Preview] Multinode Dashboard Binaries

Could you post a hex dump of the first few characters of your node1.json file?

00000000: 7b22 6964 223a                           {"id":

The code expects the file to start with a ‘[’ or ‘{’ character. It prints the invalid JSON format error if it doesn’t.

I filed a ticket for the illegal base64 data at input byte 20 error. storagenode info --json incompatibie with multinode add · Issue #4949 · storj/storj · GitHub As a workaround I think the output from storagenode info (without --json) or storagenode issue-apikey should work.

Yeah that would be the issue then!

I just ran storagenode info until I got an output that had no special characters and put it into the webui. Which was a bit tedious for 12 nodes, but did work.

Thanks for the bug reports! I created a second issue to ignore the byte order mark multinode add fails on byte order mark · Issue #4950 · storj/storj · GitHub

1 Like

I messed around a bit.

I did a fresh install of Windows 11 and it came with Powershell 5.1. Powershell 5.1 or earlier defaults to UTF-16. You can output UTF-8 in two ways. Either set this default:

$PSDefaultParameterValues['Out-File:Encoding'] = 'utf8'

Or alternatively replace > with | out-file foo.txt -encoding utf8

But in that case you still get the byte order mark, which in that case is 0xEF 0xBB 0xBF (which is 0xFF 0xFE encoded in UTF-8). The command still fails. @clement made a change to remove this here https://review.dev.storj.io/c/storj/storj/+/8252

Powershell 7 can be installed manually and defaults to UTF-8 without BOM so there this is no longer necessary and it “just works”.


I am trying to add nodes to my MND, I have successfully added the windows nodes that I have.

I have other nodes on RPi’s using DOCKER. when I trying to run storagenode info --config dir /mnt/storj/storagenode I get bash: storagenode: command not found.

I don’t know where to run this command from with this setup, does anyone know?

docker exec -it <yourSNcontainername> /app/storagenode issue-apikey --config-dir config --identity-dir identity --log.output stdout
1 Like

Awesome thanks!! That would have taken me ages :slight_smile:

Still no proper guide in Docs for Multinode Dashboard? I have to read 99 replays to understand how to set it up…

Isn’t the step by step manual in the very first post?

It’s a tech preview, not a finished product. It’s unreasonable to expect polished end user documentation. And no, you don’t have to read 99 replies, unless you want to. You also don’t have to run the tech preview software.

Not sure what are you trying to say?


You pointed me to another topic. I see different instructions there from those in this topic.
Anyway, I’m trying to say that after 1.5 years of development, I thought that it’s a finish product and should be a proper guide in Docs for any newbie that wants to try it, because it’s a useful tool. And you cand find about it reading the forum, not in the Docs. The forum should be optional for any SNO.
And yes, I read the entire topic to figure out where to run those commands, for different OS-es and node installs, and if there are recent updates, or problems that I might encounter.
And still… I have questions ananswered.


You can always ask your questions and someone will always respond.

1 Like

Does anyone have a new Docker image for this? The old Docker image no longer works.

The “old” image still works fine for me.

Can you show me the command you use to run it? Mine errors.

version: "3.3"
    restart: unless-stopped
    user: 1001:1001
    image: storjlabs/multinode:latest
      - 18002:15002/tcp
      - /home/storagenode/.local/share/storj/identity/multinode:/app/identity
      - /home/storagenode/.local/share/storj/multinode:/app/config

Is the multinode folder mount to app/config an empty dir?

PS: Is there an easy way to convert a regular docker command to docker-compose? Trying to figure out how to make my storagenode use docker-compose but having some troubles. Could you share yours?


if the path /home/storagenode/.local/share/storj/multinode doesn’t exist. Here should be a multinode’s database.

You can use this example:

Thank you! It used to be an error because I was providing it with a directory with something in it.


Since v1.70.2 was released, my multinode dashboard has updated its image too and now the disk usage historical graph is not working anymore.

Does this happens to everyone? Is it a bug?

I believe so. You need to rollback it to 1.69.2