The nodes do not work after changing the motherboard

I have installed a new motherboard. The old one had a flaw. The network adapter stopped working after a few hours.

The nodes are not working. There is no way to make them work again.

I have checked the windows firewall. The rules for opening the ports are fine. If I do a port test the ports are closed.


your network ip changed, or you reinstalled and your firewall antivirus or such thing blocks the connection… verify that there is a open route on the correct port to the correct ip from your router to your storagenode.

you most likely had a static ip setup before for the port forwarding from the router… and the network interface card (nic) was onboard, and when you reinstalled new drivers the nic configuration was reset and you got a dhcp ip address instead…

change your ip back to the static ip address your portwarding in your router is configured for.
of the cuff best guess i got

Try this checklist

1 Like

Even your service is not starting, check config, like hdd letter is the same, id is on same pcace, you have same local ip

The mac address of the network adapter changed. Enter the router to change the settings.

I have tried starting the nodes.

In toolbox they appear as online.

On the dasboard they appear as offline.

The hard drives are working.



try using the browser refresh button, the one on the storagenode dashboard have been kinda weird lately…

or maybe check the logs, to verify the that storagenode is actually running… i like to do that… just to see a successful upload and download… just because then i know.

i don’t normally do this… but when i changed a lot… then i like to just check… sometimes one catches something that one else would have missed.

Based on the Last Contact listed I would think your new motherboard and therefore OS don’t know the current date and time.

1 Like

i have also tried that multiple nic’s may cause the dashboard to use a different ip than i expected…
so i have a specific ip defined in the run command not sure how that works on windows tho…

else i’ve tried that the dashboard simply didn’t start correctly but that was after an update and stopping the storagenode and starting it again seemed to fix it…

the current date and time idea is pretty good, tho windows will in most cases sync time when its online, unless on specifically turns it off…
tho in the past if the date was off, it didn’t work… not sure if thats relevant anymore… kinda doubt it.

but still the time sync thing required is very precise, it might not have synced right and then the satellite communication or whatever won’t work allow the node to boot correctly…

in the past one was required to install a NTP client to sync the time… not sure how that is for v3, check the documentation.storj.io

Toolbox, show service status not node online status

Crtl-F5 may be help?

I have updated the windows time. The time has not changed.
I have updated the dashboard page.
I have rebooted.

How can I see the record?

Please, check logs from that node. The way is: https://documentation.storj.io/resources/faq/check-logs , but you should change the path to the logs.

The ports are still closed. When I can reboot the router.

Seems your node is trying to work.
Please, check its port on the https://www.yougetsignal.com/tools/open-ports/ while it’s running.
If port is closed - then you need to check your port forwarding rule, firewall, external address.
If port is open, then you need to check your second identity (correct path in the command): https://documentation.storj.io/dependencies/identity#confirm-the-identity

your new pc got new local ip, did you corelated port forwarding to that ip?

The port appears to me as closed.

I have already changed the settings on the router.

Already solved.
The ports on the fixed ip address was on the old computer.
I have changed the ip address and it already goes online.