Trouble setting up on rpi3

I have followed this guide:

Everythings works great until i get to this point

I have set the UUID: 968A-CE45 that is for SDA2


After reboot, the rpi is dead. Only way to get it to work again is a format of SD card.
Any hints for me?

I am using it headless by the way.

It cannot be so short. And the case of characters matters! Linux is case-sensetive.
Please, provide the output of the command

sudo blkid /dev/sda2

Do not reboot until you tried sudo mount -a, it will throw an error, if something wrong, otherwise it will mount the disk and you can check that:

df -HT

The guide says that i should use UUID, not PARTUUID… I’m not shure :open_mouth:

NEVER use exFAT. Please, backup data and format it to ext4, then restore data.
If this an empty disk - then format it right away, as described in the guide. You must use /dev/sda2 as a disk in this case.

So this might be the reason for the pi not booting after fstab-edit? I will try to reformat it now, even though gdisk (according to guide) is not found.

You must use only UUID from the output.
If you want to try your luck - you can specify exfat instead of ext4 in the /etc/fstab. It will work, but you will lose your node sooner or later due to power loss, because this FS is not designed to be easy recovered, they simplify a lot. It’s designed for Photo/Video cams, not for intensive data storing/sharing.
You also sacrifice a lot of space, because cluster size on exFAT is big, but stored files relatively small, thus you will waste up to 40% of the space.

You can install it

sudo apt update
sudo apt install gdisk

That seems to be the fix, it rebooted and works now :slight_smile: Thanks


I’m guessing this guide is made for someone with a bit more knowledge of linux than me.

I’ve downloaded the with the command, can confirm it being in the folder.
sudo apt-get unzip confirms that unzip is already instaled.

Seems the identity was not downloaded.
Could you please, install curl:

sudo apt-get update && sudo apt-get install curl -y

Then try to download again. You can skip the installation commands.
I would not recommend to generate an identity on Raspberry Pi - it could take week(s).
If you have a PC/Mac, I would recommend to generate it there and then transfer to the disk for data.
If you do so, you should modify the path to the identity in all commands (/home/pi/.local/share/storj/identity/storagenode to something like /mnt/storj/storagenode/identity, where /mnt/storj/storagenode/identity - the folder with 6 files belonging to identity).
Don’t forget to authorize the identity with an authorization token and check it before transfer to the RPI: Identity - Node Operator

The identity binary would not be needed after authorization.

1 Like