Trouble with Storj NodeJS SDK

Hi there,

I’m relatively new to Storj in general. I’ve managed to play with the Uplink CLI quite a bit, but wanted to venture to integrating Storj into my own applications.

I came across this SDK:, and tried to get going with it, but had some issues on macOS. Has anyone else experienced the following?

NodeJS Version: 12.16.1
macOS Version: 10.14.6
Golang Version: go1.14.2 darwin/amd64

The following error is persistent when attempting to use storj-nodejs in my project:

        throw e;

Error: dlopen(/Users/bader/Documents/Coding/storj-test/node_modules/storj-nodejs/build/Release/storjnodejs.node, 1): Library not loaded:
  Referenced from: /Users/bader/Documents/Coding/storj-test/node_modules/storj-nodejs/build/Release/storjnodejs.node
  Reason: image not found
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:1208:18)
    at Module.load (internal/modules/cjs/loader.js:1002:32)
    at Function.Module._load (internal/modules/cjs/loader.js:901:14)
    at Module.require (internal/modules/cjs/loader.js:1044:19)
    at require (internal/modules/cjs/helpers.js:77:18)
    at bindings (/Users/bader/Documents/Coding/storj-test/node_modules/bindings/bindings.js:112:48)
    at Object.<anonymous> (/Users/bader/Documents/Coding/storj-test/node_modules/storj-nodejs/libUplinkNode.js:1:38)
    at Module._compile (internal/modules/cjs/loader.js:1158:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1178:10)
    at Module.load (internal/modules/cjs/loader.js:1002:32)

iI appears I can run HelloStorj.js in the root of the repo (after cloning and building storj-nodejs ), but anything trying to utilize libUplinkNode.js outside of the root of the repo is a no go.

Seems to maybe be a node-gyp build issue when it comes to macOS? Not familiar with node-gyp, so unsure. Any feedback or guidance here?


Hi @crackthecode - was this all resolved?

1 Like

yes - all resolved, thanks everyone! :slight_smile:

Solved issue:

1 Like