Trying to setup my node for the first time. Its having problems

I finally got my isps stupid firewalls disabled. The web interface was all green and the information was accurate. Im checking it now to find it says its misconfigured and offline and all the information is defaults. Checking the container it keep crashing every minute or so.
container die
network disconnect
network connect
and keeps repeating, faster and faster.
When i use the node monitor in cli it works for about 3 seconds then dies saying “Error: manager closed: EOF”
After that it fails to start again it says
docker exec -it storagenode /app/
2022-07-17T19:22:28.431Z INFO Configuration loaded {“Process”: “storagenode”, “Location”: “/app/config/config.yaml”}
2022-07-17T19:22:28.433Z INFO Identity loaded. {“Process”: “storagenode”, “Node ID”: “redacted by poster”}
Error: rpc: dial tcp connect: connection refused

I did check just to be sure my ports are still open and contactable.
Ive tried removing the docker container and restarting it but doesn’t change anything. It seems to work less every time i try it. Im on a pi4 running ubuntu server. PLz hulp

Can you please post the last 30 lines of your node log?

How do i generate/find that?

1 Like

The 4th line from the bottom is telling you what your problem is.
I cannot copy it as you did not paste the output as text.

How do i actually fix that? The drive automatically mounts on start up to the same location and I’ve copied and removed files from it. Its working. The error is pretty vague. Does that mean the mount address i gave doesn’t work? Is something configured wrong is why it says it doesn’t match?

It created a folder in the drive and wrote files in it. It cant be addressed wrong

You are operating one node with 2 different Node IDs where they need to be the same ID.
I don’t know what you did to cause this, but it seems like for some reason your “storage-dir-verification” file in the storage directory has not the correct same ID like your identity.
You can’t mix different storage with different identites, every node with its storage data is 100% unique.
If there is no data yet in your storage folder then I would delete it and re-run the setup command with the existing identity. This would re-create the storage folders and a new matching storage-dir-verification file.

I think i fixed it. I deleted all the files on the drive and redid the " Setting up the Storage Node" Step before the node activation. The web interface isn’t working still but the cli looks all good. im not seeing any crashes or errors in the logs now. Getting engress and ingress now so probably working. If i remove the storage node and redo the config will that break it or damage the data i just started storing? I think i need to change its local IP for the web interface to work

i just did it and my data seems to be safe. Weirdly enough i have to set my local ip. The to its actual local ip otherwise the web interface doesn’t work. But when i change it to the local ip the cli interface fails. but i guess im fine with only having the web interface. Thanks for the help. i think my problem is solve. At least this one

You mean to remove the Docker container? Like running the docker stop and then docker rm command?