Unable to enter the local IP

Unable to enter the local IP x.x.x.x: 14002 in the browser to open the dashboard, but enter 127.0.0.1:14002 can open it , how should set it?

In your docker run command you need to use “-p 14002:14002” so that the dashboard is available on other IPs than the 127.0.0.1 as in the default run command.

The standard command is this :
docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 127.0.0.1:14002:14002
-e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX”
-e EMAIL="user@example.com"
-e ADDRESS=“domain.ddns.net:28967
-e STORAGE=“2TB”
–mount type=bind,source="",destination=/app/identity
–mount type=bind,source="",destination=/app/config
–name storagenode storjlabs/storagenode:beta

But you didn’t read this https://documentation.storj.io/setup/cli/dashboard

Edit for typo, ta alexey

2 Likes

if your system has multiple ip’s then the webdashboard can select one of the other ip’s rather than the one you expect… else it could be your local firewall that needs a port open, or you simply use the wrong ip address when trying to connect to the webdashboard… you will need to use your lan ip not the global ip that you use for the storagenode.

like andrew said, you can set a static local ip on in the run command, where you are selecting the port 14002, so

becomes
-p 192.168.0.64:14002:14002
if your local system ip is 192.168.0.64 ofc…

Hello, I am using windows10 operating system. There is a config configuration file under the installation folder. I modified the server address of the api gateway and frontend app # console.address: 192.168.0.230:14002 and restarted the service. Enter 192.168.0.230 in the browser: 14002 still can’t open

You also need to remove the # at the start of the line with that setting.