Unable to get QNAP NAS Port Open

So I’ve had a pi running a 500GB node for nearly a year.

Recently got a QNAP TS-253D NAS for local camera storage and decided I wanted to transfer my node and start sharing 1TB.

For the life of me though, I can’t get 28967 open to the world, I can switch it back to my pi without a problem, trying to get it open on the NAS though…

I have been trying to run it via CLI since it’s something I’m familiar with and forum opinion seems to be that it’s more reliable.

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967
-p 14002:14002
-e WALLET=‘arbitrarystring’
-e EMAIL=‘myemail@gmail.com
-e ADDRESS=‘mydns.org:28967
-e STORAGE=‘1000GB’
–mount type=bind,source=’/share/shared/storagenodeidentity/’,destination=/app/identity
–mount type=bind,source=’/share/shared/storjdata/’,destination=/app/config
–name storagenode storjlabs/storagenode:latest

Here is what the network on my NAS looks like.


Here are the network settings appearing for the storagenode in container station after startup.

Hi, I have a TS230, these are the screenshots


Did you open port 28967 on the modem?

Do you have a working ddns service?

Hey, thanks for sharing.

Tried adding UDP, but no luck.

I do have duckdns working, it runs just fine on the pi behind the same WAN, I just remove the pi IP entry and add the QNAP NAS IP 192.168.1.3 for port forwarding on the modem/router.

BA

1 Like

Still some routers require a restart when adding / changing settings …

Hello @BoscoAlbertBaracus ,
Welcome to the forum!

Please, show logs from the container: How do I check my logs? - Node Operator

How do you update the DDNS address? I would recommend to use router for that (the option usually in the DDNS section). Make sure only one DDNS updater works in the same time.

To make UDP working

docker run -d --restart unless-stopped --stop-timeout 300
-p 28967:28967/tcp \
-p 28967:28967/udp \

have you tried using myqnapcloud.com as ddns?

Started it this way and I’m still unable to get the port open on yougetsignal.

I know I don’t need to restart my router to change IPs, I started on another pi to verify.

I made sure my router has both UDP and TCP open, I feel like the NAS is rejecting the request, but I don’t know how to verify.

I’m not using myqnapcloud.com as ddns, I’m using a basic shell script with curl that runs in a cron, this has proven effective on many devices on my network.

Maybe you need to configure your ddns also in the network section of the qnap


and in any case to do a test with the qnap ddns does not cost anything

No, it should be configured only in one place in the network to avoid collisions

What is in the logs?