Unable to mount USB drive after rebuilding the storage node

Hello,

My raspberry pi got crashed due to some kernel issues and I could not fix those issues. I need to rebuild the node again. After rebuilding, when I connected the USB drive to the pi, I could not mount it. I get the following error. I do not want to format the drive. Is there a way to resolve this issue?

mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

[ 2501.970145] sd 1:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[ 2501.978004] sda: unknown partition table
[ 9387.289324] JBD2: Unrecognised features on journal
[ 9387.289340] EXT4-fs (sda): error loading journal
[ 9826.466769] sd 1:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[ 9826.475169] sda: unknown partition table
[10460.040501] sd 1:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[10460.048125] sda: unknown partition table
[10752.531883] JBD2: Unrecognised features on journal
[10752.531901] EXT4-fs (sda): error loading journal

Hello,

Please, show result of these commands:

sudo lsblk
sudo blkid

Here you go.

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 7.3T 0 disk
zram0 253:0 0 122.7M 0 disk [SWAP]
zram1 253:1 0 122.7M 0 disk [SWAP]
zram2 253:2 0 122.7M 0 disk [SWAP]
zram3 253:3 0 122.7M 0 disk [SWAP]
mmcblk0 179:0 0 14.9G 0 disk
|-mmcblk0p1 179:1 0 100M 0 part /boot
`-mmcblk0p2 179:2 0 14.8G 0 part /

/dev/mmcblk0: PTUUID=“76e92800” PTTYPE=“dos”
/dev/mmcblk0p1: SEC_TYPE=“msdos” LABEL=“BOOT” UUID=“D53B-9C84” TYPE=“vfat” PARTUUID=“76e92800-01”
/dev/mmcblk0p2: LABEL=“rootfs” UUID=“0cd17b3d-39ae-4b12-a1c7-9b0a96daefe2” TYPE=“ext4” PARTUUID=“76e92800-02”
/dev/zram0: UUID=“eeb8b401-34b2-4705-a21e-aaf2b5f3d0b8” TYPE=“swap”
/dev/sda: UUID=“05d57eef-f115-47e4-945d-0cb5f31f972d” TYPE=“ext4”
/dev/zram1: UUID=“bdbd9d6c-0706-4ca7-983b-8c47918f91c6” TYPE=“swap”
/dev/zram2: UUID=“2ce05c5a-ed4d-4af7-8dc2-0e5d8207663c” TYPE=“swap”
/dev/zram3: UUID=“663db47e-2b1f-48cc-89fc-058c65f21822” TYPE=“swap”

Have you added your /dev/sda to the /etc/fstab?
Or try at least

sudo mount -t ext4 /dev/sda /mnt

Thanks @Alexey

I tried that and get the same error.

pine64@StorJ-Node:~$ sudo mount -t ext4 /dev/sda /mnt/storagenode/
[sudo] password for pine64:
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

Try to fix issues:

sudo fsck /dev/sda

I tried that too but no luck.

fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
/dev/sda has unsupported feature(s): metadata_csum
e2fsck: Get a newer version of e2fsck!

I tried e2fsck also. I got bunch of errors.

You need to have a new version of e2fsck

dpkg --print-architecture
lsb_release -a

Thank you @Alexey . I have latest e2fsck and e2fsprogs. Still get the error. What would I lose if I format my drive?

You need to start from 0 as formatting would lose all data, you’ll fail audits.

You need New identity, everything.

Fortunately there isn’t a wait for new invites, but you’ll still have to wait out the audit period. ~1 month. Where your in/out is quite crappy.

@kajar9 I backed up my identity. So, I do not need a new invite. I know that I will lose the data, but what will be impact of losing that data.

You need a new identity You will get DQed because you lost all the data.

@Alexey, I ran newer version of fsck on the disk, but still cannot mount. :frowning:

pine64@StorJ-Node:~$ sudo e2fsck.static /dev/sda
e2fsck 1.43.4 (31-Jan-2017)
/dev/sda: clean, 673761/244191232 files, 187584451/1953506645 blocks

sudo mount -t ext4 /dev/sda /mnt/storagenode/

What does it say?

Thanks for the reply. I get the same error.

mount: wrong fs type, bad option, bad superblock on /dev/sda,

Try to fix the filesystem

sudo e2fsck.static -p /dev/sda