Unable to resolve host 'version/storj.io' for wget

I had my power go out this morning and my node did not return online with all my other services. When investigating I get this error ‘Resolving version.storj.io (version.storj.io)… failed: Temporary failure in name resolution.’

I have read some older topics on this and this is what I have tried so far.

  • Clear out all my storj images and pull the latest for a new container
  • Add --dns entry to use Google DNS.
  • I updated my Ubuntu box that this is running on to use google servers
  • I applied updates and rebooted the server

I do not think this is because of a slow DNS resolve. Whenever I attempt to resolve the DNS from the OS running the node and my other machines on my network, I get a response in less than 1 second.

Any help would be appreciated. I guess at this point I’m just going to let it keep error and maybe it might resolve later.

This probably still is a DNS problem, but just one of your container if you can ping version.storj.io outside the container.

–dns is of no avail, as you can read here: Container networking | Docker Documentation

Looking at that document. I saw another option to add a host file entry.


This entry did allow the node to get pass the DNS not resolving, but now I am getting a contention time-out error.

Tell us more: on what OS are you. Is it running in a VM? Are you connecting straight to the internet, it are you using VPN?

I am running this on a VM.

Host OS: VMWare
Guest OS: Ubuntu 20.04

After more testing, it seems that my container is not allowed any access to the internet. I executed a console on the container and then attempted to do wget https://google.com and it failed to resolve.

Look here: devops - My docker container has no internet - Stack Overflow

Would try these options, to start with:

cat /etc/resolv.conf

in container?

If nothing special, then on host:

sysctl -w net.ipv4.ip_forward=1
sudo service docker restart


pkill docker
iptables -t nat -F
ifconfig docker0 down
brctl delbr docker0
docker -d


sudo ip link delete docker0
sudo systemctl restart docker


Tried all those.

I just finished going more extreme option and reinstalled docker and it now working. Looks like something happen to docker and it just didn’t like it.

But I do appreciate you taking your time in helping me troubleshoot this.