Unable to run script on Identity

I have attempted to follow the instructions but when pasting the command into powershell I get an error.

I’m attempting to run
[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12; curl https://github.com/storj/storj/releases/latest/download/identity_windows_amd64.zip -o identity_windows_amd64.zip; Expand-Archive ./identity_windows_amd64.zip . -Force

It continues to fail and doesn’t install on Windows, any help please?

Welcome to the forum, @Lloyd .

What is the error message, please?

it is not instalable aplication, it shold run in command line with proper arguments as told in manual

Hi @Lloyd
The default location requires administrator rights, so it should work fine if you run powershell as administrator:

Otherwise change the path to one within your user profile, then run the command.

The default location in PowerShell with user’s rights is their profile.
The problem more like in:

  • they trying to run the command in cmd.exe
  • they uses a very outdated PowerShell (Windows 7 for example)

Sorry for the late reply, COVID got me. I keep getting this error message

I did attempt to run the command on both cmd and powershell both admin mode and user, for some reason I keep getting the same error

why do you open file in system32 folder it usualy not download it there

Ok I’ve attempted to follow the Storj YouTube setup guide and I still get this error

What version of windows are you using?

Windows 10, everything is up to date

Im able to run it in powershell without admin without any errors.

I’m scratching my head like an ape, it creates a zip folder in storj2 but there’s nothing in the identity_windows_amd64 zip folder… do I have the wrong powershell? It’s powershell 7 x64

Using windows 11 and windows 10 without issues. Try just running it in a default location.

I tried that, I attempted it in system32 but that failed too, I attempted a few locations but they all show the same error message

Are you running it natively or are you going directly to the folder where powershell is located? Cause you should beable to goto start and search powershell and open it there.

Yea that’s where I open it, I have run in both admin and normal

Also it seems you manually installed powershell cause I dont even have a folder for it, Its probably the reason it doesnt support the zip files.

I downloaded powershell7.2.2 from the Microsoft Docs, I will try and use the x86 version

Not sure why you would need to manually install it windows 10 comes with powershell. Its really not important though you can manually unzip it and run it manually if you needed.