Unraid node issues - wonder if Storj may be the problem? (4774 processes seems running!?)

The last week I have had some issues with my unraid is getting slow. among things I’m running storj on it.
This could very well be unrelated to storj, but I’ll ask the question - last time I had issues the Storj would not shutdown, everythign else stopped, except Storj, I even tried using kill in the terminal.
And when doing so I noticed there was (If I read it right) 4774 threads for Storj.
Is that normal?
Now, I don’t know if that is the issue, but just wonder if anyone else is seeing similar issues?

Update - Once I had the system up and running again, it seemed to show a more reasonable amount of threads:
after a couple of hours I had another look and it was up to about 80 some threads (Not terrible).
Then a bit later it seemed to have taken a turn for the worse with 1045,
and about 20s later I ran pstree again and it showed 1206:
I not checked this when everything is normal, but I can’t imagine that this is normal?

are you mounting ext4 with unassigned devices or using xfs/btrfs with unraids array?

I could guess, but you also see a huge memory usage (GiB instead of MiB), right?
This is usually related to a slow disk or filesystem.

Slow disk performance writing Storj Data is likely what it was. I’m getting more data and writing directly to the array + it was writing to a slower SATA disk (since unraid needs to read data to update the parity disk this is probably the reason)
I moved it to a cache pool last night and it’s been running great over night

1 Like

To avoid these problems I have it as unassigned and formatted as ext4. Much better performance than xfs


I second that. ext4 is a best FS for storagenode at the moment