Updated Docker and Storj Not working

Hi All,
I updated Docker today and after restarting my Mac and Docker restarting Storj no longer is working and there is no container at all. Seems like something happened and its all gone. What do I do? I am a newbie and got Storj up and running in Docker around 4 months ago and this is my first time something has gone wrong just after I started earning.
Any help would be very much appreciated.


When you rebooted did you check if your StorJ drives mounted to the same spot as before?

What does the output of the following command give you?:

docker logs <storage_node_name_here>
1 Like

Hi Doom4535, Thank you for your reply and suggestion. I ran the script in terminal and get the error No such container: <storage_node_name>

For some reason the container seems to be gone.

Any ideas?


Maybe the docker update flushed the container.
Cant you just add it again?

Im a newbie and not sure what to do to add the container again. If someone can point me in the right direction or help me it would be great.


Hello @rowdymuncher ,
Welcome to the forum!

Did you store somewhere your docker run command?
If not, I would suggest to do so and create a bash script to run storagenode with CLI text editor, for example - nano.
The template of the command you can take there: Storage Node - Node Operator
For watchtower there: Software Updates - Node Operator
You need substitute your values for each <whatsever> placeholder including < and >.

If you do not know, what you specified instead of placeholders 4 months ago, you can try to find them by history | grep docker command in your terminal.
If search give no result, you can form them from scratch.

Perhaps you didn’t move your identity, so you can try to get a full path to it:

echo ~/.local/share/storj/identity/storagenode

To see what’s path to your disk:

df -H

I hope that you know what was your wallet address and you still have keys from it.

Please, do not run a setup step with SETUP=true! It could destroy your node!

Hi Alexey,

Thank you for your help. I followed what you asked and below is the result from Terminal. I have not moved the identity.

efraimsilver@BTFSNode2 ~ % docker start storagenode
Error response from daemon: No such container: storagenode
Error: failed to start containers: storagenode
efraimsilver@BTFSNode2 ~ % history | grep docker
991 docker ps -a
992 docker ps -a
1000 docker logs 12nzGuwn2DiyrN9ZVYTAN6x2nLPL2bBT4XJAjUEHRTdkmZuBwPC
1001 docker run -d --restart unless-stopped --stop-timeout 300 \ndocker start storagenode
1002 docker start storagenode
efraimsilver@BTFSNode2 ~ % df -H
Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
/dev/disk2s1 3.1T 11G 855G 2% 488393 30482971527 0% /
devfs 216k 216k 0B 100% 730 0 100% /dev
/dev/disk2s7 3.1T 2.2T 855G 73% 5331656 30478128264 0% /System/Volumes/Data
/dev/disk2s4 3.1T 6.3G 855G 1% 6 30483459914 0% /private/var/vm
map auto_home 0B 0B 0B 100% 0 0 100% /System/Volumes/Data/home
/dev/disk5s1 4.0T 393G 3.6T 10% 649796 39067487644 0% /Volumes/StorjStorage
/dev/disk6 999G 938G 61G 94% 2423320 4292543959 0% /Volumes/Seagate Backup Plus Drive
//admin@DiskStation2._afpovertcp._tcp.local/Plex 12T 11T 210G 99% 2758190281 51384240 98% /Volumes/Plex

I am at a loss on what has happened. Docker is now showing this below after I had run the command:

efraimsilver@BTFSNode2 ~ % docker run -d --restart unless-stopped --stop-timeout 300 \

docker start storagenode

Unable to find image ‘docker:latest’ locally

latest: Pulling from library/docker

540db60ca938: Pull complete

5a38b3726f4b: Pull complete

e5fa5deb3340: Pull complete

c521bbbd9945: Pull complete

59707d521c45: Pull complete

26abe223b186: Pull complete

9d806bc20361: Pull complete

Im not sure what to do next.


Hmm, did you name the original container storagenode?

When you ran docker ps -a earlier, did it show any containers (and what details did it show)?

Could you put your console stuff inside triple back ticks? This will format it so that it is easier to read, should look something like:


A post was merged into an existing topic: Node not working offline

Hi oom4535,

I ran the command docker ps - a in terminal and got this result. I can’t understand what has happened.

713b27aba741 docker “docker-entrypoint.s…” 2 days ago Restarting (1) 3 seconds ago trusting_shockley

That looks like your node is actually using an auto generated name of trusting_shockley and looks like it is likely stuck in a reboot loop (so never actually finishes booting).

Are you able to post a longer output of your logs?:

docker logs trusty_shockley

If I had to guess based on the default name, it is missing the path to your storage and identity files.

For reference here is what I use:

docker run -d --restart always --stop-timeout 300 \
    -p 28967:28967 \
    -p 14001:14002 \
    -p \
    -e WALLET="<wallet_address>" \
    -e EMAIL="<email>" \
    -e ADDRESS="<my_domain>:28967" \
    -e STORAGE="1.8TB" \
    --mount type=bind,source="/path/to/Identity",destination=/app/identity \
    --mount type=bind,source="/path/to/Data",destination=/app/config \
    --name StorjNode-01 storjlabs/storagenode:latest \
    --debug.addr=":5999" \
    --filestore.write-buffer-size="2MiB" \
    --log.level info

For the ticks, try using back ticks instead of single quotes (on a standard US keyboard this would be the key below escape, not sure on other layouts).

This might help figure out the key:

When running the command docker logs trusting_shockley in Mac Terminal I get the following hundreds of lines.

error during connect: Post http://docker:2375/v1.24/containers/storagenode/start: dial tcp: lookup docker on no such host
Error: failed to start containers: storagenode
error during connect: Post http://docker:2375/v1.24/containers/storagenode/start: dial tcp: lookup docker on no such host
Error: failed to start containers: storagenode```

Looks like this is some other container.

docker stop trusting_shockley
docker rm trusting_shockley

I see that path to the storage is /Volumes/StorjStorage, now let’s figure out where is identity.
Execute commands:

ls -l ~/Library/Application\ Support/Storj/identity/storagenode
echo ~/Library/Application\ Support/Storj/identity/storagenode

Please also show result of the command:

ls -l /Volumes/StorjStorage

Please, run the storagenode: Storage Node - Node Operator, replace all <whatever> placeholders (< and > included) to your actual values.
Do not use any wordprocessors include Notes, they will replace straight quotes " to curly ones, double dashes -- to hyphen and so on, use only text plain editor or nano in the terminal.

I would recommend to put the whole command to the bash script, i.e. start-node.sh for example, and save it to /Volumes/StorjStorage.
This way you would not need to remember what was where.

Hi Alexey,

thank you for all your help. Here is what was shown in terminal up to running the storage node script. Can you help me with that as I don’t want to stuff it up and not sure what parameters to use.

total 48
-rw-r--r--  1 efraimsilver  staff   562 28 Jan 04:12 ca.1611767547.cert
-rw-r--r--  1 efraimsilver  staff  1088 28 Jan 04:12 ca.cert
-rw-------  1 efraimsilver  staff   241 28 Jan 04:06 ca.key
-rw-r--r--  1 efraimsilver  staff  1100 28 Jan 04:12 identity.1611767547.cert
-rw-r--r--  1 efraimsilver  staff  1626 28 Jan 04:12 identity.cert
-rw-------  1 efraimsilver  staff   241 28 Jan 04:06 identity.key
efraimsilver@BTFSNode2 ~ % echo ~/Library/Application\ Support/Storj/identity/storagenode
/Users/efraimsilver/Library/Application Support/Storj/identity/storagenode
efraimsilver@BTFSNode2 ~ % ls -l /Volumes/StorjStorage
total 80
-rw-------   1 efraimsilver  staff   8447 28 Jan 10:22 config.yaml
drwx------   5 efraimsilver  staff    160 30 Jan 02:44 orders
-rw-------   1 efraimsilver  staff  32768  4 Jun 20:39 revocations.db
drwx------  49 efraimsilver  staff   1568 10 Jun 20:13 storage
-rw-------   1 efraimsilver  staff   1377 10 Jun 19:11 trust-cache.json
efraimsilver@BTFSNode2 ~ %

Hi Alexey,

Please disregard the last reply. After doing an update to docker and restarting storj node started working again. I think I am all good now.

Thank you so much for all your help

1 Like