Uplink cli error

Hi, Everyone.

developing software using uplink-python, uplink cli on Ubuntu server.

when using this command “uplink cp epnrrxlsbg.jpg sj://upload-bucket/epnrrxlsbg.jpg”, first time is okay, but twice time got this error.

attached below link

However, I can many uplink cli call in short time.

I think uplink setup is good (include Satellite Address, API key, pharsepass)

Do you have any idea?

any help also would be better.

Thank you.

For some reason your DNS server is unable to lookup the satellite address.
Could you please try to use or as your DNS address instead of your current one?

Thanks for your reply.

I tried to and tried command.

But get same error

Your network is pretty unstable. Could you switch to wired connection?

Perhaps it would be better to use rclone with gateway MT configuration. It would not open many connections like uplink and may be your network would allow to upload normally without interruptions.

I am using VPS ubuntu.

I think VPS speed and connection is good.

should I change server?

Perhaps it has issues, can you check from other VPS server of this provider?
Sometimes re-creating the server is enough to solve an underlaying issues, but it depends on provider of course.
Please also check their conditions - perhaps they have some rate limits or limit how many connections you can open (uplink opens 110 connections for upload for each segment (segment is less or equal 64MB)).

1 Like