Upload fails with error Remote Exception

Hi, new to Storj. I’m trying to do my first upload from the command line but I get this error:

PS C:\temp> .\uplink.exe cp C:\Users\charl\Desktop\test.txt  sj://homestead
Created sj://homestead/test.txt
.\uplink.exe : 0 B / 33 B [___________________________________________________________________________] 0.00% ? p/s33 B / 33 B 
[----------------------------------------------------------------------->] 100.00% ? p/s33 B / 33 B 
[----------------------------------------------------------------------->] 100.00% ? p/s33 B / 33 B 
[-------------------------------------------------------------------->] 100.00% 55 B p/s33 B / 33 B 
[-------------------------------------------------------------------->] 100.00% 55 B p/s33 B / 33 B 
[-------------------------------------------------------------------->] 100.00% 55 B p/s33 B / 33 B 
[-------------------------------------------------------------------->] 100.00% 51 B p/s33 B / 33 B 
[---------------------------------------------------------------------] 100.00% 25 B p/s
At line:1 char:1
+ .\uplink.exe cp C:\Users\charl\Desktop\test.txt  sj://homestead
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (0 B / 33 B [___...00.00% 25 B p/s:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError

I just created a small test file. The connection works. I could list the buckets and create new ones. I just cant seem to copy or put.
Any idea what my problem could be?

Hello @Charlie ,
Welcome to the forum!

What is the upload speed in your location? You can use speedtest.net to check it.
Do you use some restrictive firewall on your Windows PC or on your router or in between?
If you use a firewall - is it allows connections from your Windows PC to any destination and port?

Please, give me result of the command:

Get-Acl C:\Users\charl\Desktop\test.txt

And this one

.\uplink.exe ls sj://homestead

Please try to upload with --log.level debug option and post results.

Hi Alexey, thanks for responding. Here is the Get-Acl:

PS C:\temp> Get-Acl C:\users\charl\Desktop\test.txt

    Directory: C:\users\charl\Desktop

Path     Owner      Access                                                                                                        
----     -----      ------                                                                                                        
test.txt AHAB\charl NT AUTHORITY\SYSTEM Allow  FullControl...

Here is the “.\uplink.exe ls sj://homestead”

PS C:\temp> .\uplink.exe ls sj://homestead
OBJ 2021-08-06 20:59:43       721401 dragonfly.jpg
OBJ 2021-08-06 21:01:44       721401 Dragonfly.JPG
OBJ 2021-08-06 21:03:33           33 test.txt

So it looks like the file was created last night, despite the error.

When I do a cp today with the debug option I get this:

PS C:\temp> .\uplink.exe cp C:\Users\charl\Desktop\test3.txt sj://homestead --log.level debug
.\uplink.exe : 07:16:27.758	INFO	Configuration loaded
At line:1 char:1
+ .\uplink.exe cp C:\Users\charl\Desktop\test3.txt sj://homestead --log ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (07:16:27.758	INFO	Configuration loaded:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
	Location: C:\Users\charl\AppData\Roaming\Storj\Uplink\config.yaml
07:16:27.758	INFO	Anonymized tracing enabled
07:16:27.779	DEBUG	started
07:16:27.779	DEBUG	debug server listening on
Created sj://homestead/test3.txt
17 B / 17 B [----------------------------------------------------------------------->] 100.00% ? p/s17 B / 17 B 
[--------------------------------------------------------------------] 100.00% 111 B p/s07:16:28.215	DEBUG	stopped

My internet connection is only 20MB but I get the same behavior when working off my hotspot so I don’t think it is my router. The files seem to be copying but the output from the commands makes me think its not working.


There is some weird error. Could you re-download an uplink binary?
Please, give me result of the command




Please, also try to use cmd.exe instead of PowerShell

Hi Alexey,

Looks like maybe the powershell is being too restrictive. I ran the commands and found this:

PS C:\temp> $PSVersionTable

Name Value

PSVersion 5.1.19041.1023
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0…}
BuildVersion 10.0.19041.1023
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3

PS C:\temp> Get-ExecutionPolicy

When I ran the command with cmd.exe everything worked fine.

Thanks for the support!
1 Like