Upload success very low

Hi All,

I’ve downloaded and run the successrate.sh script and this is from the upload section:

========== UPLOAD ============= 
Rejected:              171059 
Acceptance Rate:       40.468%
---------- accepted ----------- 
Failed:                27 
Fail Rate:             0.023%
Canceled:              114675 
Cancel Rate:           98.619%
Successful:            1579 
Success Rate:          1.358%

The Success Rate is abysmal. I’ve read a number of threads and the reason seems to be that I am losing races to other nodes. What I am looking for here are possible suggestions that could help win more of these races. The Rejected rate also seems high to me, is that expected?

Anyway, the following are my OS and CPU information:

storj@pine64:~$ uname -a
Linux pine64 3.10.105-bsp-1.2-ayufan-136 #1 SMP PREEMPT Sat Oct 27 21:18:35 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux
storj@pine64:~$ lscpu
Architecture:          aarch64
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             4
CPU max MHz:           1344.0000
CPU min MHz:           480.0000

Any help would be appreciated.

It is a known bug, success rates are inaccurate right now.


This topic may be helpful to find out what parts are slow.

Also look at use of system resources to see if there are any bottlenecks. It seems you still have a max concurrent requests limit set, otherwise you would have no rejected transfers. What did you set it to?

The issue linked by @Cmdrd will also have a big impact though. So looking at other things should be done in the context of trying to optimize, not because there is necessarily anything wrong with your node.

1 Like

Did not know about those debug functions to get this, thanks for the info there, will have to get that enabled on my nodes, more information to work with for node hardware performance improvements.


Thx, the debug port should come in handy, I will add the debug port.

I do have the max concurrent limit set, should I remove that? It is currently set to the default value of 7 because when I had it set higher it was complaining so I figured I would just set it to what the config.yaml says is the default value.


Thx, I was aware that those were incorrect.

yes. It should not be set. The default is unlimited.


Thx, I have changed the config.yaml to this now:

# set the concurrent max request (default 7)
#storage2.max-concurrent-requests: 7

Please, do not forget to save the config and restart the node.

Do in need to do a stop/start or a restart?

If you changed the config, you need to restart the node. You can do it as stop, then start or as just restart, depending on the version the command will be different. You can take this guide as a base: https://documentation.storj.io/resources/faq/system-maintenance