Upload via uplink on FreeBSD with pf (firewall) enabled not possible

Continuing the discussion from Upload not possible:

I’ve been stuck this issue since I have replaced my machines with FreeBSD. Its standard firewall, pf, does not seem to allow random port number and you need to disable it to upload a file with uplink.

https://www.freebsd.org/doc/handbook/firewalls-pf.html

PF understands port names as well as port numbers, as long as the names are listed in /etc/services .

What should be a practical solution here? Currently I stop the firewall each time to upload the file, which I would like to avoid if possible.

Thanks,

1 Like

I really don’t see a reason to block outgoing connections with a firewall, especially if you allow outgoing connections to all ips on at least one port.

right- since my machines are owned just by me there is no point of being worried about outgoing connections…

Yeah, unless you want to really lock the PC down (to the point of only bing able to browse certain whitelisted websites and such) then I don’t think allowing all outgoing connections would reduce the security.

Totally agreed with you. Thanks for letting me understand the basic concept of setting firewall :grinning: