V1.13.3 reports as v1.12.3 after manual update

Hello ! I have download from GitHub new version 1.13.3 - two files - storagenode.exe and storagenode-updater.exe
Stop the services. Just copy and overwrite the files. Start the services.
And in dashborad I have a version number - 1.12.3.

Very good update ! :wink:


This post is very miss leading…Not sure if your being serious or you don’t know that you cant just update right away?

I am as serious as possible. I honestly downloaded the new version. But in the dashboard, she writes the wrong number. What’s so funny?

You wrote this so yeah, and who is laughing?

it is relise bug, insede 1.13.3 update 1.12.3 version file.

What I’m talking about. And what to do?

It was sarcasm… And I put a smiley at the end of the sentence.

I taged developers, will see, i hope it just taping mistake in file version

1 Like

Sorry I don’t run windows so I have never gotten an update on day one of a update, And I didnt think windows did either, guess im wrong.

1 Like

@DeSad75 I hope you don’t mind, I cleaned up your topic title so it is a bit more informative

You do everything right :slight_smile:

Problem solved.

1 Like

Thanks a lot ! I’m going to update again :wink:

1 Like

Now that’s great! Problem solved, thanks everyone! :wink:


What is the last version for a Debian storj node? Currently have 1.12.3 version with automatic update configured. But I don´t know if is working good the autoupdate or if apply more later than nodes with Windows. I’m worried.

The docker image is still on v1.12.3.
We are 40% in the updater rollout and as last step the docker images are rolled out.

1 Like

Just right now! :wink: