Version differences in powershell and dashboard

Two of my three nodes show different versions between the dashboard and the powershell. The dashboard shows version 1.11.1 and the same node in powershell shows 1.12.3
Where this error?
Attached image

It’s your browser cache. Try in private mode to see.

It is not a cache problem.
I have cleared the browser cache.
I have tried in private mode
I have tried with another browser

The difference between versions continues

For multiple nodes on the same PC you should map different ports for the dashboard too. I.e., -p 14003:14002, -p 14004:14002 and so on.
If you have a Windows GUI here too, then next node should not use the 14002 since it’s already occupied.

The nodes are on different PC’s

Does the web dashboard and cli show same node id ?

Yes, I only have the node on the computer and the ID is the same in the dashboard and powershell

Fixed by restarting the service

One of my Windows nodes shows version 1.11.1, but StorageNodeUpdater.log states it´s running version 1.12.3.
Is it supposed to?
Tried CTRL+F5 on Dashboards, still the same:

Can you check after restarting service ?

Storagenode service or storagenodeupdater service?

No harm in doing both

It solved it.
Restarting storagenode service updated dashboard to last version :wink:

1 Like