Watchtower automatic update on Email

Today I got email about upgrade storage node to latest version and see that automatic upgrade command is not updated:

Please replace it for correct command from here

docker run -d --restart=always --name watchtower -v /var/run/docker.sock:/var/run/docker.sock storjlabs/watchtower storagenode watchtower --stop-timeout 300s


I was wondering if that would work. As always, you’re on point! Thank you. Wouldn’t it be good to also add --stop-timeout 300s to the run command for storagenode as well?

NOOOoooo… We tried that and it made watchtower stop and remove the container, but never start it again. Learned that the hard way.

Use docker stop -t 300 storagenode and docker restart -t 300 storagenode instead when stopping or restarting.

1 Like

Is there a way to force this when doing a reboot, or do you just manually stop before rebooting?

The method you mentioned would be the way to do it while rebooting, but the incompatibility with watchtower makes that not an option. So for now, I would say manually stop. (Don’t forget to manually start again as well)

Today new release is came, but EMAIL is not changed:

@jocelyn can someone update this text or just a past link to the documentation?

1 Like