Watchtower warning

Hi all!
i’ve just added watchtower to my node on rpi4 and got the following warning:

pi@raspberrypi:~ $ sudo docker run -d --restart=always --name watchtower -v /var/run/docker.sock:/var/run/docker.sock storjlabs/watchtower storagenode watchtower --stop-timeout 300s
WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm/v7) and no specific platform was requested

It says its running, but can i expect it to update the node correctly even with the warning?

pi@raspberrypi:~ $ sudo docker ps -a
b163838763e2 storjlabs/watchtower “/watchtower storage…” About a minute ago Up About a minute watchtower
5753c86eb530 storjlabs/storagenode:latest “/entrypoint” 10 days ago Up 10 days

Hello @dieseldic,
Welcome to the forum!

You can ignore this warning. The arm64 is suitable for armv7.
But keep an eye on it anyway, when the new docker version would be published. It should update the version in the 12-72 hours after that.

Great, thanks for the prompt reply!

@Alexey Their post said amd64, not arm64. That seems like it shouldn’t be working. I mean, it looks like it is, but it seems weird unless the user has binfmt_misc and qemu-user-static enabled or something.

I don’t think I have anything enabled that wouldn’t be on the storj setup instructions. Fairly new to Linux and the pi’s.
I just don’t want it to have a failed update and end up with my node down

Then I would suggest to check our manifests to support armv7 and do not try to resolve it to amd64


So watchtower doesn’t work as expected on Raspbian? Just curious as I’m running a node on it

It does, I have been running nodes on pis for over a year and watchtower has worked.


Same as @dragonhogan here: Been running nodes on a RPi 4B for more than 18 months now, and watchtower has always updated my nodes correctly.

1 Like

Thanks @dragonhogan and @Pac for the answers

1 Like