WD MyCloud Ultra EX2 and RaspberryPi4

After a long research on how to get the storage node working on WD My Cloud Ultra Ex2 i found the following approach working for me i would like to share a few points.

1 I used raspberry pi 4. As is it not easy to install docker daemon on the NAS itself
2. I mounted the nas share to the pi. I attempted with three protocols NFS, CIFS/SMB iscsi.
3. With NFS and CIFS, it is easier to set up, but the MySQL database will not be happy with it and will cause some issues. With iscsi things work better. but the setup is more complicated as you need to create a volume, formate it, and mount it to the pi.

The network filesystems like NFS/CIFS/sshfs/etc. are not supported, only iSCSI can work normally, but you need a reliable network anyway.

why not use docker directly on my cloud ex2. one of my node is on ex2.
you can get docker bin built by community here:

2 Likes

I actually tried installing docker on my WD ex2 but didn’t work. Perhaps i tried the wrong binary. I will try this one, thank you for sharing

I have tested this, using docker on WD MyCloud Ultra EX2 works far better than using pi and mounting iscsi or other volumes.

1 Like