Weird issue with storagenode on synology docker


Trying to run storagenode container on synology docker (DSM7).
The container starts and then stops. Error is:

downloading storagenode-updater stdout

22:31:54 --2022-03-25 22:31:54-- stderr

22:31:59 Resolving ( failed: Try again. stderr

22:31:59 wget: unable to resolve host address '' stderr

22:31:59 http://: Invalid host name.

This is not a DNS issue on the server. DNS works just fine.
I believe this should be a typo or some other error on the image?

Any ideas?


Hello @Slewrate,
I also use Synology and DSM 7 and had exactly the same error as you. → Docker 1.50.4 restarts many times after "unable to resolve host address ''" - #3 by sembeth

It is recommended in the documentation to use “–restart unless-stopped”. → Storage Node | Storj Docs

So some of my storagenodes could not resolve the DNS and stopped automatically every time. Due to the “–restart unless-stopped” they automatically restarted and finally after a few restarts they were able to resolve and download the updater and storagenode binaries and it worked.

I’m not sure if it has something to do with our DNS or Synology. I use Cloudflare ( as DNS Server.

1 Like