What happend to the ?view option for a linkshare?

I was sure that there was a ?view option for the linkshare link which made it possible to directly stream and view media files. Now this does no longer seem to work because I only get offered the to download the file then. Has this been removed or changed on purpose? Because it was a good option to stream and no good idea to remove it.

Here an example link: sintel | Tardigrade

And for what formats does the streaming work? Because mkv file does not stream and I believe this is a streaming format too?
Example link: mkv format

?wrap=0

http://link.tardigradeshare.io/s/1N2isb7JVSzs8s9w91f2f8XMBfdkqinvSWrP9poPYQWbAuUhrb6TX7V3YbLCsu5vJkq4oHwkz6QP4mpJZswF3nZPzC3nUbvFWRfuXjdzJVLfHMvSVDPRZH2KxegRNpTKPcf2XbRYmD7yfmkuZzuhVyS3A12BemXRF9w7pYutQPbBJgbiaWzh1PxpkbrhR3hzwUs4QUPNX3PgT5psNo2G6mYUf7rxrftK81WYE9jSTBh7c8FoDVyYg3KFzRsZveSSHHHodNtWqLxJ4jgR4Wf685aS7KEESMVqpgBB5PNvfgEEWRF49/sintel/sintel2048surround512kb.mp4?wrap=0

I have tried that but this also only displays the download dialogue.
I mean of course in the linkshare page it is embedded. But when I call the link directly, I only have the option for direct download.

In Chrome and Firefox on my computer it loads the video directly and then doesn’t ‘stream’ the file until I click play.

I have just tried Microsoft Edge and it downloads it immediately.

Agreed. Edge seems to go straight for download.

That means its going to be file handlers within the browser.

I tried with Firefox and I agree it streams right away.
The PIP function of this player is really neat. :grinning:

With the ?view argument the direct streaming had worked previously. I wonder what change caused it to make it no longer work.

1 Like

Using ?view it streams in Firefox but downloads in Brave and Safari. Will create a ticket to investigate. Thank you for reporting.

Looks like the fix will be out soon. Thank you for reporting.

3 Likes

Meanwhile you can replace /s/ in the URL to /raw/ to have the same result.
See Share a Restricted Access to an Object - Tardigrade

Just wanted to report that I am getting still/again a file offered for download instead of streaming: https://link.dcs1.storjshare.io/raw/jxqy2wdbf5qeaxo4a2eq6yw3gthq/videos/Storj%20Final.mp4?wrap=0

Could you please try in FireFox?
For the Chromium-based you can try to replace the /raw/ to /s/ in the URL

Firefox streams fine.
Edge is also only offering the file to download no matter if I use the /raw/ or /s/ option.

You also need to remove ?wrap=0 for the url with /s/ instead of /raw/, i.e.
https://link.dcs1.storjshare.io/s/jxqy2wdbf5qeaxo4a2eq6yw3gthq/videos/Storj%20Final.mp4

If you want to embed it - then the ?wrap=0 is must have, see:

Unfortunately not. When I try:

https://link.dcs1.storjshare.io/s/jxqy2wdbf5qeaxo4a2eq6yw3gthq/videos/Storj%20Final.mp4 → Firefox and Edge: Map distribution

https://link.dcs1.storjshare.io/raw/jxqy2wdbf5qeaxo4a2eq6yw3gthq/videos/Storj%20Final.mp4 → Edge: File download, Firefox: Stream

https://link.dcs1.storjshare.io/s/jxqy2wdbf5qeaxo4a2eq6yw3gthq/videos/Storj%20Final.mp4?wrap=0 → Edge: File download, Firefox: Stream

https://link.dcs1.storjshare.io/raw/jxqy2wdbf5qeaxo4a2eq6yw3gthq/videos/Storj%20Final.mp4?wrap=0 → Edge: File download, Firefox: Stream

Yes, the Chromium-based (include Edge) cannot stream directly some kind of containers, depends on video type, encoding, etc.
I do not know the exact reason for that. But the FireFox (and Safari if I’m not mistaken) are working like you expect.

However, if you embed the URL to the page, or post it on the forum with /s/ and ?wrap=0 it would working in most browsers as expected.

1 Like