When my raspberry pi reboots the docker container wont restart showing offline on dashboard

when my raspberry pi reboots i am getting an offline on dashboard

I run comand docker ps -a

getting a a status on the container of exited (128) 2 minutes ago ( and counting

when i run command docker restart storagenode (PROBLEM SOLVED)

but i don’t want to have to manually do that every time the pi reboots i might not be here!

how can i solve this?

Show last 10 lines of the log

They do start, if the docker daemon is started and you used a documented docker run command and also have a static mount.

Ah, I stand humbly corrected. My node’s uptime is over 300 days now, so I clearly forgot what happened at last reboot.
(Although I could have sworn the nodes didn’t start automagically!)

I will delete my erroneous post, then, so as to not mislead anyone and to try and save whatever little is left of my self respect :wink:

The node could not be started, if docker daemon not started after boot. By default it starts own service on first call of any command. You need to enable it to being started automatically: Post-installation steps for Linux | Docker Documentation