Why does Web show OFFLINE while dashboard.sh shows ONLINE?

Hi,

I had run the node for almost one month. Yesterday i found I couldn’t connect to Web, so rebooted the machine and docker, but the status on web gui is always OFFLINE. When using “docker exec -it storagenode /app/dashboard.sh”, the status is ONLINE. My storj docker is running on centos, version v0.28.2.

Can anybody shed some light? Thanks!

Try to use Chrome or Firefox. Try to press the Ctrl+F5

I tried Chrome, Safari and Firefox on Mac, IE and Chrome on Windows, but no luck.

Please, try in incognito mode.

Also, please, check your identity: https://documentation.storj.io/dependencies/identity#confirm-the-identity

I don’t know about incognito mode, could you elaborate it?
I tried following and look like the result is right.
[root@localhost ~]#grep -c BEGIN ~/.local/share/storj/identity/storagenode/ca.cert
2
[root@localhost ~]#grep -c BEGIN ~/.local/share/storj/identity/storagenode/identity.cert
3

In the Chrome browser there is an incognito mode. Please try to open a dashboard in it

I got the same result in incognito mode.

Please, press F12, navigate to the console and press the Ctrl+F5, did you see any errors?

no error found. everything looks fine.

Please, give me result of this command:

docker exec -i storagenode wget -qO - localhost:14002/api/dashboard

Do you have more than one node?

I have only one. Here comes the output:
{“data”:{“nodeID”:”xxxxxxx”,”wallet”:”xxxxxxxx”,”satellites”:[{“id”:”xxxxx”,”url”:“satellite.stefan-benten.de:7777”,“disqualified”:null},{“id”:”xxxx”,”url”:“asia-east-1.tardigrade.io:7777”,“disqualified”:null},{“id”:”xxxx”,”url”:“us-central-1.tardigrade.io:7777”,“disqualified”:null},{“id”:”xxxxxxx”,”url”:“europe-west-1.tardigrade.io:7777”,“disqualified”:null}],“diskSpace”:{“used”:4332910080,“available”:800000000000},“bandwidth”:{“used”:14535620608,“available”:10000000000000},“lastPinged”:“2019-12-27T00:17:38.022330051Z”,“lastPingFromID”:“1111111111111111111111111111111112m1s9K”,“lastPingFromAddress”:"",“version”:“0.28.2”,“allowedVersion”:“0.27.0”,“upToDate”:true,“startedAt”:“2019-12-26T17:51:10.073849903Z”},“error”:""}

Dashboard is working. Then the problem with a browser. What is your browser?

I tried Chrome, Safari and Firefox on Mac, IE and Chrome on Windows.

Is your port open on the https://www.yougetsignal.com/tools/open-ports/ ?

yes, both 14002 and 28967 are open.

I’m assume that your port is open on the https://www.yougetsignal.com/tools/open-ports/

Please, check in the developer’s console (usually F12), do you have any errors when you refresh the page?

1 Like

Why do you open port 14002 in your router?

I have found the cause. Looks like it’s due to incorrect system time. Thanks for the help!

2 Likes

I didn’t recognize that it’s not a must. Thanks.