Windows GUI Node Tip

I was having one of my Windows nodes randomly stopped working.
Service was running but no traffic.
After many troubleshooting, I realized it was the NIC Power management that was on.
Once I shut it off, no more problems. Might help someone and avoid DQed.


Care to share which exact NIC and driver version you are using?

Well, apparently it’s something else :frowning:

Someone else having this?

The 118 satellite is shutdown, so everyone see this.
Regarding traffic - there is fluctuations as well, nothing new. I would not expect a constant traffic, except audits.
If you see the audit requests in your logs and they are successful downloaded - then your node working fine.
You also can check your Audit score on each satellite to be sure.

But I get notifications from uptimerobot and when I check my node the port is closed.
If I restart the service, dashboard shows offline.
When I reboot it, it starts working.

This is weird. Could you check your router? Perhaps it has some “optimization NAT” feature enabled, which closes port after a while.

Indeed @Alexey, I’m an IT. Besides having portforwarded now, I even tested in the DMZ!!
It’s weird as F!
And the thing is, when I reboot it, I have to manually start storage node and update services, because after the reboot they’re both stopped.
Uninstall and reinstall?

I’ve noticed intermittent port closure when ddos protection is on on my router. Could be worth a look.

Thanks @BrightSilence, I thought of that, but I have no DDoS protection on my router. I disabled the router firewall though. It’s online for 30 consecutive hours…which is a record :stuck_out_tongue:

Well that seems a little extreme. Make sure you don’t do that with direct addressable IPv6 systems on that network. Won’t be anything protecting them that way.

Thank you for your feedback, IPv6 DHCP is disabled on my network :smiley:
I have firewall disabled, but now where are it, I’m going to enable it again, just to troubleshoot for sure.

Yup, firewall enabled for over 80 hours and node running @BrightSilence.
Weird as F…the only difference was configuring DDNS service on the router itself instead of the Windows DUC client.