Windows Installer - a few improvements needed

Here is couple of things that the Windows Installer does not perform correctly. It is not critical, experienced node operator will overcome it manually easily, but maybe for new operators it may be helpful when fixed:

  1. Right upon starting the installer I get this message, not sure how you as a program author can avoid it, but I’m not seeing this when installing any other software (Obviously I do click More info > Run anyway, but it does not look that trustworthy)

  2. As for following screen:
    image
    – when no port is specified by the user, only the IP, use the default, do not require to type it in when I want the default port
    – on the other hand, in the description below [The storagenode will listen … on port 28976] show real port that user has specified (if I set it to :30000, show …on port 30000), or at least mention something like by default it will listen on 28967”

  3. The Installer will create firewall rule TCP in 28967 allow no matter what different port I provided to the Installer

  4. The Installer will not create any UDP in firewall rule

  5. In config.yaml the Installer will make correctly contact.external-address: 10.20.30.40:30000 (that is what I entered during the installation), but will not change accordingly line server.address: :28967

Hence, out of the box the node will not work due to 3 and 5.

Otherwise it works great on Windows :slight_smile:

Hi @xsys ,
I shared your feedback with the team.

1 Like

As a simple SNO, and although I do not host anything on Windows, I do appreciate you taking your time to write such detailed post.

Many thanks.

1 Like

Great findings, good work.

It will use the port, specified as listening on your host, i.e. in the server.address: option. There you have :28967 and it’s used to create a rule. There is no UI field to change that port during the Wizard though.

These are two separate ports. You can configure the port forwarding from 3000 TCP/UDP to 28967 TCP/UDP and this is a default suggestion, so this listening port is not necessarily should match your external port.

Thank you for deeper explaining. Then it may be good to include server.address: option in the initial Windows Installer GUI as well.

Now I understand the difference between contact.external-address and server.address. Maybe it’s only me, but I always tend to forward the same port to the machine and change the listening port on the storj app, instead of on the NAT. Always I prefer changing the port of the listening app, instead of translating the port on the NAT. I have experiences where changing the port during NAT would not work (confuse) some apps / servers, especially on Windows.

Nonetheless, it will still not work out of the box when using non standard port, as described above, and also it will never create UDP in rule in any case.

Just my 50 cents, I’m not complaining, I can deal with it, just thinking of others :slight_smile:

2 Likes