Yesterday Node was Set, Status OFFLINE


I have same problem , Yesterday Node was Set, Status OFFLINE.
Using Huawei HG8245H,
Done Port Forwarding
Done DDNS settings, using no-ip
Checked Port - matching
Firewall settings set with Inbound rule created
but PORT 28967 - No route to host…Port is closed
on cmd — netstat -aon
TCP [::]:28967 [::]:0 LISTENING 4512
What did I missed??

Hello @Filip ,
Welcome to the forum!

WAN IP could be changed by your ISP or the local IP of your device with storagenode could be changed by router.
If you uses DDNS, then check its updater.

Thanks @Alexey
The port finally open.
NODE status Still Offline.

I cannot post more than 2 post , i am a new user !!


Then please, show 20 last lines from the logs: How do I check my logs? - Storj

when open logs i can see this
dial tcp
now i have new ip address
on DUC shows status ok, open port 28967 checked
and the new IP address is 46.217.121.***

You specified a public IP in the node’s configuration. If it’s a Windows GUI, then install Notepad++ and edit "C:\Program Files\Storj\Storage Node\config.yaml", replace the IP to your DDNS hostname, make sure that there is no spaces between address and port, save the config (menu File - Save, confirm Administrators request, click menu File - Save again to finally save it), then restart the storagenode service either from the Services applet or from the elevated PowerShell:

Restart-Service storagenode

If you use a docker version, then to update any parameter, you need to stop and remove the container

docker stop -t 300 storagenode
docker rm storagenode

Then run it back with all your parameters include changed ones. You need to change the IP to thre DDNS hostname in the -e ADDRESS option.

Tnx @Alexey , done, now is online