Zksync opt-in disappeared

Dear Storj community,
I noticed that the yesterdays payout over July was done to my wallet address on the Ethereum layer 1 network instead of zkSync. I opted-in for zkSync with operator.wallet-features: [“zksync”] in the config.yaml file. All worked well till now. I received the payout on the zkSync network or the past 10 months (verified on zkscan.io).

I am running a single node on a windows machine with version v1.84.1. I check the log file (in debug mode), no errors or warning concerning the wallet-feature after a node restart is showing up in the log file.

Are you experiencing the same problem?

Just to add some maybe useless datapoint : i opted into zksync era and lite and the payment went to zksync lite

Did you opt into era and it fell back to l1?

Hello @marcelvd,
Welcome to the forum!

Please check your dashboard, does it show that you opted-in for zkSync?

Hello Alexey,

Thank you for the quick reaction. The dashboard did show the zkSync opt-in in the past 10 months. Now it is no longer shown in the dashboard.

Hello Andrew2.hart,

I did not opt-in into zksync era. About 10 month ago I opted-in to zkSync lite via the config.yaml. That worked flawless till yesterdays payout.

1 Like

After comparing a previous version of my config.yaml, I found the root cause. Previously, I manually added operator.wallet-features: “zkSync” at the end of the yaml file. Last month I moved it to the beginning of the file.

I overlook that the default config.yaml already contained an entry <operator.wallet-features: “”>, causing a reset of the wallet feature.

I deleted the line < operator.wallet-features: “” >. Now the yaml file contains a single line for operator.wallet-features. After a restart of the windows service all is working flawless again.