Can´t open Dashboard

Hello there,
so i checked my node 3 hours ago at the docker exec command worked fine(also the web interface at xxx.xxx.xxx.xxx:14002 worked completly fine).
Now i want to check my node again and if i type in the docker exec command it loads the first two lines that say "
2019-10-03T21:56:01.749Z INFO Configuration loaded from: /app/config/config.yaml
2019-10-03T21:56:02.108Z INFO Node ID: xxxxxxxxxxxxxxxxx" (xxxxxxxxxxxxx stands for my node ID)

And in past this two lines show for a maximum of 5 sec and than the Dashboard loaded.
Now i can wait 5 Min and nothing happens, also the webinterface doesn´t load at all.
If i type in my Browser xxx.xxx.xxx.xxx:14002 it starts the request but never recive any Data.

if i type docker logs storagenode i get:

2019-10-03T22:03:19.334Z INFO Configuration loaded from: /app/config/config.yaml
2019-10-03T22:03:19.353Z INFO Operator email: my_email@email.tld
2019-10-03T22:03:19.353Z INFO operator wallet: 0xXXXXXXXXXXXXXXXXX
2019-10-03T22:03:19.945Z INFO version running on version v0.22.1
2019-10-03T22:03:20.134Z INFO db.migration.23 Split into multiple sqlite databases

I also checked if my system failed at some point (also restarted) but nothing.
I checkt if my DynDns and my Portforwarding is active but all of them are normal.
Also done “docker stop storagenode” --> “docker rm storagenode” and than rund the “docker run” command but as expected nothing.

So my question is is this a Bug of Storj or the Storagenode v0.22.1 ? or does my PC make a misstake?

Please, show the docker logs --tail 40 storagenode

Multible times this Error:

ERROR   piecestore      failed to add order     {"error": "ordersdb error: database is locked", "errorVerbose": "ordersdb error: database is locked\n\tstorj.io/storj/storagenode/storagenodedb.(*ordersDB).Enqueue:52\n\tstorj.io/storj/storagenode/piecestore.(*Endpoint).saveOrder:622\n\tstorj.io/storj/storagenode/piecestore.(*Endpoint).doDownload.func4:583\n\tstorj.io/storj/storagenode/piecestore.(*Endpoint).doDownload:606\n\tstorj.io/storj/storagenode/piecestore.(*Endpoint).Download:365\n\tstorj.io/storj/pkg/pb._Piecestore_Download_Handler:1096\n\tstorj.io/storj/pkg/server.(*Server).logOnErrorStreamInterceptor:23\n\tgoogle.golang.org/grpc.(*Server).processStreamingRPC:1127\n\tgoogle.golang.org/grpc.(*Server).handleStream:1178\n\tgoogle.golang.org/grpc.(*Server).serveStreams.func1.1:696"}

But now the Webinterface is back up and shows the node as Online but the Console interface over “docker exec …” isn´t there at all

So now after a second reboot of the maschine the console works as well but it says “Last Contact ONLINE” is that normal?

Pretty normal. Just read the https://forum.storj.io/t/changelog-v0-22-1

2 Likes

But is it also normal that no bootstrab-address is shown?

This sounds like a latest tag instead of beta in your docker run command

Hey! Just checked and can confirm! The bootstrap server doesn’t showed

1 Like

docker run -d --restart unless-stopped -p 28967:28967
-p 14002:14002
-e WALLET=“0xXXXXXXXXXXXXXXXXXXXXXXXX”
-e EMAIL="myemail@gmail.com"
-e ADDRESS=“mydomain.net:28967
-e BANDWIDTH=“200TB”
-e STORAGE=“3TB”
–dns=8.8.8.8
–mount type=bind,source="/identity",destination=/app/identity
–mount type=bind,source="/data",destination=/app/config
–name storagenode storjlabs/storagenode:beta

thats the docker run command i used

So it´s normal or is it a bug?

also my neigbourhood size isn´t shown

Let’s call it “feature” unless proved :slight_smile:

Because there is no kademlia anymore

Ok that cool “feature” :rofl::+1:

Also i write a support message and added an Idea on ideas.storj.io for the auto Update Function in the webinterface.
It ends with an error so i wrote it my self and sent it to you.
reason: the “document.getquerySelector(…).click()” function ends in an error so just use “document.getElementsByClass(name)[0].click()”

If you want to know which support ticket nr it was:
2199

Bootstrap server is a part of the kademlia, so it doesn’t needed anymore. Only the text is remained

you can add it here:


The community should know our heroes :slight_smile:

1 Like

So, to sum it up, expected changes to the dashboard with v0.22.1 under storjlabs/storagenode:beta are that

  1. No more Last contract (DHT gone), will just say ONLINE.
  2. No more neighborhood size (again, DHT gone)

Running v0.22.1 under storjlabs/storagenode:arm had ONLINE for last contract, but was still showing neighborhood size.

I’m on ARM and have moved over to :beta, all is peachy! :slight_smile:

also, lots of upstream for me since start of Oct. with just 0.8TB, om-nomnomnomnomnomnomnom.